In game photos (using F10) NOT uploading since last update! [SOLVED]

Past few rides photos I take in game are no longer uploading to my strava- I haven’t changed any settings and my Zwift settings for photos is the same ( my photos only)…any idea why they all of a sudden wont upload?- seems to be since the new upgrade. Not showing up on the companion app as well



I am also having this issue. No screenshots are saved after rides at all - not even to Zwift itself (and neither Strava, of course). This has been happening since last update, across two different Windows 10 machines, on four different rides.


I am also not seeing any screenshots since Oct 24th in Zwift Companion and on Strava despite making several screenshots with the hotkey (Windows 10). When i finish the ride i can see the screenshots beeing uploaded but they never appear.


I have same problem. Windows 10 machine, up to date. Since last Zwift update some or all of the screenshots chosen for upload will not actually be uploaded, to either zwift or Strava


Same issue in windows 10. What I have noticed is that if you capture from the Companion app, those images get uploaded. Just not the ones you’ve F10’d from the PC. So this may be a workaround for now.

When you end the ride, you’ll notice how quickly it “uploads” selected images compared to before when it was working correctly.


Adding my comment here as I am also experiencing this issue (Seems to be Windows/PC specific).

I have had it where just the first photo uploads but not others … Annoying when you can see and select them to upload but they are not saving across correctly - I like to save the Ride Summary screenshot to my Strava.

Thanks for the workaround suggestion @Tajrian_Talukder … I will try doing the screen capture via the companion app on my ride tomorrow.

Hopefully Zwift will patch this soon if this is highlighted enough.


Yep, same error here. I was suspicious about how quickly the images were ‘uploading’ and it turns out they weren’t. The files exist on the PC, but not on my activities feed.

Gonna assume it’s linked to the changes made in the last full release.


Same as the above for me too…

1 Like

Some do, some dont, which is a first. I am normally getting everything thats ticked for uploading.

Not just Windows/PC it is the same on my Macbook. Looking at my rides since the weekend (24/25th). Didn’t we have a game update on Friday before…

1 Like

Okay. Seems like it is a PC/Mac issue.
I have seen ATV screenshots that still seem to be uploading, but this may be due to capturing via companion app.

I will test the companion app capture on my ride shortly, which seems to be the only workaround at the moment.

Why is my previous message now marked as “solution”? That was certainly not my doing, as my message is just a corroboration of the OP…

BTW, I am still having the issue, but will try to use the companion app today to see if that workaround works. I’d still prefer to be able to F10…

I did wonder @Pascal_Gaudette_TBR, but assumed it was marked as a solution in error. :+1:

Real solution (or temporary workaround) below, special thanks to @Tajrian_Talukder!

… the good news is that using the companion app to do the screenshots does work, and seems these will sync/upload across to Strava. Thanks again!

I will periodically test the F10 key (as I know there was a minor update for the Halloween resources today) but I am doubtful this bug would have been fixed…


:raising_hand_man:t4: Same here. Logged a ticked… hope fully should get a reply. Guess another update to fix it


Similar issue here on Windows 10 / v57840 except that taking the photos via Companion instead of F10 makes no difference. There’s no way to upload a screenshot at all.

At first, the PC application was still displaying the interface to select a screenshot, and then just ignoring the selections and uploading nothing. At some point since then, the PC application has stopped showing the interface to select a screenshot entirely.


Same here. Not uploading to zwift or strava…

Title makes it seem like this is a Strava problem, when it’s a Zwift problem.


Better now :sunglasses:


But they’re not uploading anywhere, not just Strava.

This is true, any screenshots taken using the F10 hotkey are not being saved against the activity in Zwift (companion or dashboard)

However, I have had success using the companion app to take screenshots, mentioned in my post above, which are then saved against the activity and synced with Strava.

Hoping the more comments here will highlight the issue and prompt a fix from Zwift!

1 Like