In game photos (using F10) NOT uploading since last update! [SOLVED]

This maybe has something to do with the switch to daylight saving time last weekend.

The screenshots are stored in the c:\Users<my Username>\Pictures\Zwift folder but do have the wrong filedate (1 hour earlier) using Windows 10 and the F10 hotkey. My Windows system time is correct and made the switch to daylight saving automatically.


It first happened to me on 24 Oct, before the clock change. I didn’t ride on 23 Oct, and it was working on 22 Oct.


I made screenshots with the companion app today like suggested in this thread and those pictures were attached to the strava activities. So that’s the workaround for now until the bug gets solved.


Me too, it works with the Companion App, but… Only pictures taken just with your phone. I tried to mix’em up to see if it would take the “F10” pictures also but No. It skipped them!! So of 5 pictures 3 of them with ZCA was uploaded and the 2 from F10 (PC) was Not Uploaded but skipped. Hope Zwift fix this soon. Now I have to go to pictures/Zwift and ZIP the pictures from todays rides and get them to another computer and manually upload them to Strava, or you can just manually upload them from your Zwift Computer to Strava.

1 Like

I am having the same issues too with F10. Sometimes having Companion App open helps but most of the time it is not uploading the captured pictures. The pictures still are available in the Pictures folder on my Windows machine. Like everyone else, it started happening after an update…

Same here. Sometimes 1 picture will go through. Most of the time nothing uploaded.

Also just to add a little more, it is not just Strava. If i go into Companion app later ( Taken whilst on a PC) No photos are in companion.

If I look back a week / few weeks and I can see all the pictures I screenshot from my rides just fine.


Checking my log files, it looks like this bug was introduced with v1.0.57620.


Completely removed Zwift, renamed Zwift folders, and Zwift Picture folder. Downloaded clean install and same thing, reverted back and copied Zwift Folder CP and preferences back. Same thing, Companion App works fine.

1 Like

Any acknowledgement of this from Zwift?

1 Like

I haven’t seen any official comments from Zwift on this… maybe the timezone change / timestamp is the issue which will resolve itself over this weekend :thinking:

But if the issue continues, it would be good to get some acknowledgement from Zwift.

The workaround of using the companion to take screenshots (which then appear on the final ‘save and exit’ screen) does work to get screenshots to sync across to activity on ZC / Strava etc.



A workaround is useful but also gives them an excuse not to give it attention. It’s a broken feature.

1 Like

100% agree. The more we can highlight the issue (by comments on this thread and votes) the better!



I’m having this problem, too. I use a PC running Windows 8.1 and am taking screenshots with F10, making sure that photos are selected at the end of rides. The last ride that successfully uploaded a photo was Oct. 20, and I’ve ridden multiple times since then (starting Oct. 25) with no photos uploading. They appear neither in Zwift Companion nor on Strava.

1 Like

This happened to me but all of my Zwift photos load to a “Zwift” folder in the “picture” file.
I was able to add the photo to Strava and here.
Time change hasn’t occurred yet.
I use Windows 10.

I’ve sent an email to Zwift as so far no reply on the forum here- I’ll see what they say



Do you mean you think it’s fixed?

My images from yesterday haven’t uploaded more than 24 hours later although I had two selected. So as far as I can see, it’s definitely not better.

Nah that was in reference to me whinging about the thread title, which previously made it appear like it could be a Strava issue.

1 Like

No I’m still not seeing any fix - unless the bug has been fixed in the last 48 hours