New launcher (1.0.51) causing stutter on Windows systems [SOLVED]

This didn’t affect me but I know how much grief it caused people so thanks @Steve_Clogg_PACK_LEA for this :slight_smile:


Could someone from zwift try it without these installed and see fi they can get to the source of the issue?

My guess is, knowing zwift, there is a workaround and that’ll be the last we hear of it.

Hopefully it’s an easy fix.

The other thing about this though is it raises questions about what else the devs have installed on their systems when bug testing etc (stop sniggering). Could explain the frequent Bluetooth issues, for example. Clearly they can’t account for the billions of hardware/software combinations out there, but what they can and should be doing is making sure the game runs as expected on a clean install of any given OS, to eliminate the possibility of creating these sort of dependencies.


So, where is the fix posted?
What do i have to do to fix it?

The fix is in the post. :wink:

I’ll PM you some step by step instructions. Don’t want to put them on the open thread in case it messes up someone’s system and/or ZHQ don’t want me linking to third party software here.

1 Like

With HQ’s blessing, here are the steps to follow for anyone getting this stutter and flickering on the current launcher. In case anyone’s not aware of what it is, OBS is a well-respected open source piece of software for streaming/capturing from your PC. The likes of GPLama use it to produce content. You don’t need to actually do anything with it though, just install and set it running.


  • This is a workaround, not a permanent fix.
  • What follows is clearly not designed as any sort of proper guide for OBS, it’s for the purpose of eliminating these specific issues only.
  • OBS is a significantly smaller download than GeForce Experience, and doesn’t require an account. That’s why it’s the better option. Other capturing software may also work, but I can vouch for this one.
  • If you’re having any other issues than those described, this probably won’t help.


  1. Download and install OBS from here, you want the big blue ‘Download Installer’ button: Download | OBS
  2. Run it when installed, and when the auto-configuration wizard pops up, select ‘I will only be using the virtual camera’, then click Next and finally Apply Settings.
  3. Now go into File > Settings (in OBS itself), untick ‘Automatically check for updates on startup’ and tick ‘Minimise to system tray when started’, before hitting Apply and OK.
  4. Minimise OBS.
  5. Copy the shortcut to OBS into your shell:startup folder.

If you’ve followed the steps correctly, OBS will now run silently at system startup, and Zwift will work properly without the stutter and flickering issues associated with the newer launcher(s).


Even though all indications point at my system not needing this, I’m going to give it a shot. Thank you very much Dave. This is very useful information.

Check to see if you have GeForce Experience installed and running, if so then there’s no need to also do this. :+1:

Ok I did solve the flickering for me!

Change the lanchers compatibility mode to “windows 7”.

right click the zwift.exe > properties > compatibility > compatibility mode > change to windows 7

Interesting, I’ll try that out.

I have used the Xbox Game Bar (which Windows somehow installed for me unasked) for screen recording, would that be enough to solve this as well? (Not really asking for myself, my current potato isn’t powerful enough to have these kinds of problems in the first place.)

This didn’t work on my system.

I can’t usually get the Game Bar to recognise Zwift. But I usually disable that so I tried it, didn’t work for me. As you say it’s possible that the capturing element resolves these issues though, where people can use it.

any idea what OBS adds to the equation that fixes the problem?

Not really, no. It’s something to do with how the game and driver sync to the display, that’s all I can offer. As though having some form of capturing software or overlay is creating a reference point, and if that’s not present the driver is unable to sync the frames coming from the game with the tick of the display. Clearly on the previous launchers that reference point wasn’t required.

A few of my regular rides and races later, and the OBS workaround is still working a treat. Lovely and smooth with no flickering, like the game was on the old launchers. :+1:

RivaTuner shows the frame rate consistency immediately going crazy when you close OBS. Very weird.


Glad you have found a new workaround that seems to do the trick.

Would be interesting to see why this fixes it but my guess is that as there is a workaround zwift will consider it fixed.

Add Zoom to the list of software which resolves this. Another likely reason for people not seeing it.


Interesting. Considering it as a temporary workaround but honestly I would very much prefer a solution from Zwift side and not having to install OBS, Geforce Experience, Zoom or other third party software that might avoid the phenomenon from occuring but that I would otherwise not install on my system. (No, not obsessive at all, just prefer to keep it clean :slightly_smiling_face:)

Probably not a coincidence then these three have in common that they have some screen recording/sharing functionality, but that is probably an observation most have made by now and unfortunately I have no idea in what way that interacts with the Zwift application.

Over on ZPCMR however I’ve read that they are looking into it further, so I’m hopeful. :crossed_fingers:


Completely on board with you there. That’s why I started seeing this stuff in the first place, because my rig and those I build have as little crap on as possible.