Crashes with AMD Radeon graphics [MERGED] [SOLVED]

Hi Lauren, the connection used does not matter, as I experienced the same error with ANT+
The crash happens in Watopia with AMDs latest drivers (by latest I mean its every driver since the release of Windows 11), no matter what type of connection is used. But it does not seem to happen in other guest worlds (I’m a Watopia guy so I didnt bother testing other worlds before).

1 Like

Thanks for the update! I am still rocking the driver I rolled back to from august 2020 and its been working without issue. I look forward to when this bug can get pin pointed so i can go to some more up to date drivers:)

Thanks for keeping an eye on this and good luck pinpointing the issue.

1 Like

Hi Lauren,

I can confirm that the crash happened to me this morning running the 21.11.1 optional update. I’ve also sent a bug report to AMD through Radeon Software. The issue happened with all devices connected via bluetooth on my phone (using the companion app), as we had thought initially that the issue was related to the ANT+ dongle.

I’ve sent the event viewer logs to Zwift support. :crossed_fingers: any of this helps.


I do have the same problem. Zwift keeps freezing at exactly the same location, approximately 4 min into “Road to Sky”. When riding another route, it worked fine for 40 min until I reached the exact same location, than I froze again.
Unfortunately, I can not downgrade to the older drivers, as they don’t support my RX 6600. I tried the newest version 21.11.2 and also 21.10.2. Both have the same freezing problem.
This makes me unable to use Zwift on my PC, as downgrade is not possible. It is really frustrating, esecially as the rides can not be continued and are not saved at all.

Another update: rode several hours on Makuri islands with no problems, in London my player character did flicker in the subway sections (but no crashes), which never happened before. Did another test with Road to Sky again, crash after 3-4minutes into the game.

I am 99% certain it’s the same launcher/installer issue. London is very easy to render, so you’ll have had high frame rates in that spot, hence the flickering. Here’s how to resolve it until Zwift do: New launcher (1.0.51) causing stutter on Windows systems - #49 by Dave_ZPCMR

It’d be interesting to know if this does anything for your crashing issues. Doubt it, but who knows.

1 Like

That might be the issue, for testing with the crashes I disabled vsync, so frames got into the 200fps range when riding London. Disabling vsync did not help with the crashes, so I will enable it again.

Keep vsync off for now and try the OBS workaround mentioned; it would still be useful to know if it resolves the flickering at high frame rates because then the crashing (assuming it still occurs) can be treated as a separate issue.

With OBS running in the background the flickering is gone, but the game still crashes in Watopia, tested on Road to Sky shortly after leaving the tarmac (3-4min into the route). Tested with Non-WHQL-Radeon-Software-Adrenalin-2020-21.11.2-Win10-Win11-64Bit-Nov11

1 Like


@Lauren This seems to confirm the avatar flickering is a separate issue to the crashing. The flickering is related to the game installer/launcher and @shooj is already aware of it. Good (or bad?) to know it also affects AMD cards, and can be mitigated in the same way.


Hey Dave, thanks for letting me know. I appreciate it!

I’ll update the title and description.


Thanks everyone for keeping this post going. I just wanted to provide an additional update. I am still rocking the driver from 2020 here and so far no issues. If its within forum rules i would also like to report this to amd is there a link that can be provided or a specific phrase to search on google.

Awesome, thank you for your help! I think you have to use the AMD Adrenalin Software in order to submit a report to AMD. AMD’s website provides some info on that here:

This issue exists since approx. June 2020. Before there were 0 issues with the same setup.

The latest Adrenalin 21.11.3 has still the same issue.

I find it funny that you mark it as resolved. No it is not a solution to run a 1,5y old GPU driver which does not support latest games.

I’m so tired of this freezing issue with AMD GPUs. I use a RX 5700 XT.
I don’t experience any flickering but I have freezes in all maps at different locations. Most stable runs London and Richmond.

Hi Chris,

Did you experience the issue with 21.11.3 and Zwift’s November updated, released today?

Hey Jon,
actually it was released yesterday and yes, I had a freeze again.

1 Like

Thanks, I’ll stay away from updating the drivers for a few more weeks I guess.

Well, I’m afraid this is a long lasting story as it is existing now since 17 month without any solution on horizon.

I only started having the issue in the last couple of months (Vega 56). Rolling back to 21.08.2 seems to have stopped the crashing so far. Have you tried using those drivers, at least they’re only a few months old.

1 Like

I’ve had the same issues with the new update since I just bought and installed a RX 6700 wednessday. My old RTX 970 never crashed.