Kickr Bike & Trainer resistance is non responsive in free ride [August 2021] [1.16.0]

With this update, my trainer does not change resistance when riding uphills or downhills. Only the speed changed. This is very anoying, riding flat vs climb feels completely the same.
I am using a Wahoo Kickr Bike, firmware 1.220.

6 Likes

Forgot to mention, I had the problem when using Apple TV app earlier.

I ride again with my iPhone app, I do not see the same problem.

1 Like

I have this issue on this update with a Wahoo Kickr Gen2 trainer. No resistance control on Apple TV

5 Likes

Yes. I later tried on my iphone and everything works fine. This is the Apple TV Zwift app specific issue.

1 Like

Seems like Zwift has handed code development out to the summer interns atm… Seriously QA issues

3 Likes

Not specifically to pairing, but noticed with the update today that resistance controlling on the Apple TV to my Kickr has been lost

3 Likes

The topic should not just be for Kickr bikes, bike kickr trainers also

1 Like

You guys mucked up. It’s totally broken. I’m in the biggest gear riding uphill in the jungle and no resistance.

The climb feature now doesn’t work either.

You need to either revert to the previous version or get this build fixed and then put in a change freeze until the faults in the QA process have been ironed out. This issue has occurred before with kickr bike as well this year.

Also look at the local builds and how devs are submitting changes through from local environments to the higher level environments.

We cannot do proper rides outside because of a hard lockdown so we need Zwift to at least work.

9 Likes

That’s liked to the SIM gradient sent to the bike. No gradient sent = no climb movement.

2 Likes

SIM mode testing passed here (working as expected) with the following setups:

AppleTV 4K (2021 edition) & ATV HD (Pre 4K)
Zwift Build 1.16
Kickr BIKE fw1.22.0

2 Likes

I had no gradient resistance on my entire group ride lead straight after the update this morning. Kickr V1 on Windows 10.

3 Likes

BLE or ANT+? I’ll take a stab in the dark this issue is related to the FTMS implementation on Zwift (something that’s changed recently on a few Wahoo trainers too).

ANT+ Shane. Seemed to be ok this afternoon after a full power recycle of everything.

Dang… but good!

I’m having a slightly different, but perhaps somewhat related. For me the resistance/grade gets out of sync. I can be doing a 10% grade climb and the trainer (wahoo kickr) offering no resistance, but the opposite too. If I stop pedaling and wait for the bike to stop, once I restart it takes several seconds (I’d say up to 10) before the avatar reacts and starts moving again too.

4 Likes

exact same issue with KICKR bike and ATV on new game version today, sigh. no resistance control of the bike at all.

i rolled back the KICKR bike firmware to the ( pre FTMS ) 1.16 version after and tried that as well, no difference, same issue.

At least it doesn’t matter to us ATV users that the Alpe is busted then. not the solution i was hoping for to that problem though!

please fix so it works like it did yesterday

2 Likes

I have this on Apple TV paired with my Wattbike atom. Has been working flawlessly before the update - now no resistance - very annoying.

I have the same issue with no resistance since the update. Apple TV but paired with Wattbike Atom 1st gen. Working great before the update.

Same here. Several times no resistance and spinning at the KOM. But strangely enough then I raced Herd Summer League and resistance was normal. But after that I changed to free ride in watopia and again the bug appeared. I’m using ATV with Kickr Core (newest firmware) and Zwift (newest version).

My kickr17 is behaving weird tonight with the latest Apple TV update.
Did a catch up maap stage in watopia and all was fine, logged out and in again to do a new route on the Japanese island and found I was going up temple Kom in 52-13 at about 120w as if was flat.