No resistance change when climbing


(Hugh Leonard) #1

 I am using Zwift on an Apple TV 4k and a 2017 Kickr.  I tend to get on and simply hit the big orange “ride” button as opposed to joining a ride or doing a workout.  However, there is no change in resistance when climbing; I can control my cadence, which stays about the same, and my speed drops, but no resistance change.  What am I doing wrong?


(C hris Strub) #2

Hugh, is it possible you have simulation mode completely turned off?  When in ride and not moving.  Go into Menu, Settings.  There is a slider to adjust simulation mode for the smart trainer.  For full simulation, needs to be slid to the right, for no simulation, to the left.  Middle is 50 percent.  Also, make sure you are using FE-C option at pairing screen for your kickr.  It should detect two Wahoo’s.


(Jeff Horn #EN ODZ) #3

Chris, I am having the same problem as Hugh.  Actually I have had nothing but problems with ATV and zwift.  I can finally get all my sensors paired in 50% of the time (running Kickr, wahoo cadence and 4iiii hrm).  I’ll join races, to be the only avatar in all of watopia too.  

Problem today was that once I got everything paired I joined a group and was continuously dropped due to no resistance change in my KickR.  My Avatar would slow down and speed up but resistance never changed on smart trainer.    I do workouts Tues/Thur and ERG mode in WKO is spot on, very happy with that aspect of it.  I tried closing program.  I tried restarting ATV.  I tried the trainer difficulty slider bar without any effect in the game.  I even tried clicking on “workout” and de-selecting the ERG mode radio button before riding.  

Quite frankly with all the trouble, Im ready to smash my ATV with a hammer.  It has not been the seamless experience I thought it would be.  Any help appreciated.


(Eric C. (Zwift HQ)) #4

Hi guys,

For AppleTV, there is a hardware limit of 3 Bluetooth devices (with one being the AppleTV remote). You will need to use ZML for the rest of your devices.

Make sure you are pairing everything properly that way (KICKR as Controllable Trainer/Power Source, etc…)

And, with AppleTV, it often will not actually shut down the app after you quit, which can cause connection issues. Completely close Zwift after each time you use it and then open it again - that should get everyone back within the program and you shouldn’t be riding alone.


(Ron Hock (MKE)) #5

I have the same issue. Kickr SNAP with ATV. The trainer is paired via Bluetooth as both power and controllable. When riding (not doing a workout) I can’t feel any difference going up or down hills or drafting, regardless of “trainer difficulty” setting. This makes zwift lose most of it’s entertainment value.

When I connect outside of zwift with the wahoo app, I can go to sim mode and enter slope, wind, etc and it is very noticeable. This I believe it has to do with zwift.


(Serge Tessier) #6

Hi guys.  Maybe this is and answer to your problem… I was having the same problem with me setup.  My wahoo is link no problem in zwift but nothing change in climb . 

 

Try link your wahoo as a power source and also as a controllable trainer, you must link your trainer both place.

 

It work ant+ and bluetooth.

 

good luck.


(Richard Flynn) #7

I have no resistance on wattbike atom, everything was fine until I did the update yesterday, cadence watts, training workouts are all fine but when I want to climb say the radio tower the resistance is the same ascending as descending? Tried removing app and reloading, turning every thing off etc, etc, still no joy??


(Paul Clark) #8

When i used my Tacx Neo and bluetooth HR monitor with apple tv Zwift resistance was fine. I set up my Atom on Thursday and as previous comments no resistance.

When i link the Atom to my Mac book pro using the Ant+ dongle resistance is there. 

If ATV has 3 bluetooth ports then Atom is 1 Controller is 2 and HR monitor is 3. So why does it not work?Is it because the Atom sends 2 signals Power and controllability.

I even disconnected the HR monitor but still no resistance.

Thought by getting this set up it would be the bees knees. All its bin is a massive head ache and lost time ridding all this weekend.

I have sent emailed Wattbike today. Hopefully its can be done.

On Zwifts reply. What is ZML for the other devices?


(Steven Pugh) #9

Same issues with my atv and wahoo kickr and no change in resistance. Never had these issues until using atv. Any help Zwift?


(Domien Verhulst) #10

Having the same ‘issue’ with my newly bought Tacx Bushido Smart T2780. Connecting throught te Zwift connection smartphone app. I can ride but only the speed changes when climbing no change in resistance.