Apple TV with Kickr Snap: no change in resistance up hills


(Michael Wynn) #1

The resistance works going up hills when paired with my phone but not when paired with Apple TV. Please advise.


(Paul Graham) #2

Are you using the same settings on both the phone and Apple TV. Michael?

That is, on your ATV, check you have not engaged ERG mode and that you do have controllable trainer option enabled.


(Edwin Thaves) #3

I’ve had similar problems with Wahoo Kickr since the recent Zwift update. 


(Ron Hock (MKE)) #4

Same issue.  Kickr SNAP and ATV 4K.  THis was the entire reason I bought the ATV.


(Ed Williams) #5

Super disappointing to learn about this problem the hard way.  I literally only bought the ATV for my new workout room to run Zwift and my Kickr Snap.  So far nothing I’ve tried works - I can still run it on my old computer and screen output to the TV, but that makes the ATV a nice useless brick.  Please fix this or provide some direction as to how to fix it.


(Ron Hock (MKE)) #6

I had the problem on and off at first for a while. Now I make sure Bluetooth is off on all my devices, in particular my phone in my pocket during the ride. It seems the kickr would rather talk to your phone via Bluetooth than the ATV.

You can start fresh, it does seem like once it got messed up in the ATV it’s hard to get back. Turn everything off and uninstall zwift. Then reinstall. Make sure Bluetooth is off on your phone, computer, etc.


(Ed Williams) #7

I was finally able to get mine working last night on accident.  I powered off the ATV and back on, and it wouldn’t pick up the sensor on the SNAP - it seems it re-paired itself to the Wahoo app on my phone even though I’d ensured that app was killed during earlier troubleshooting.  Once I killed the app, it immediately popped up on the ATV and was actually able to control resistance.  I’m not entirely clear on what actually fixed it, the reboot of the ATV or the killing (again) of the Wahoo app, but am hoping it stays fixed!