Wahoo Kickr Snap Resistance control has stopped working


(David Kitchen) #1

Hi,

After the last update, it seems resistance control has stopped working on my kickr snap. 

The smart trainer is still recognised, and recognises power etc, but doesn’t seem to change the resistance at all with a change in gradient.

I’m running it through bluetooth using mobile link with iOS. No other apps open. 

 

Also, as others have mentioned, the calibration spindown doesn’t work at all with this setup.

 

Any help anyone can offer would be much appreciated. 


(Jason K) #2

We’re currently looking into issues caused by the Zwift calibration, including a loss of resistance. You may be able to fix this by doing an advance spindown in the Wahoo mobile app, and then avoiding the Zwift calibration until we fix this.

Sorry for the bugs!


(Brad Brown) #3

Has this been resolved? I’m having the same problem right now. Thanks!


(David Kitchen) #4

No to the best of my knowledge, after this happened I cancelled my zwift subscription. Beta testing is fine but not on paying customers.


(Michelle Karlovich) #5

This trainer used to work fine, and now is practically unuseable.  Goodbye ZWIFT.   I actually returned my KICKR thinking that was the problem and now I have a new one with worse issues.


(Constantine Mastory) #6

Hello All!

Are there any updates on this issue? I am experiencing the exact same problem. I tried connecting the Kickr straight to my laptop through bluetooth and i also tried it connecting it using the Zwift Mobile Link but to no avail.

 


(Joachim Larsson TIS (C)) #7

(Allan Berg) #8

Is anyone from Zwift planning on responding to this thread? I can barely do a full revolution on a Kickr Snap. You guys are making Wahoo look terrible


(Scott Santoro) #9

I have been using the apple TV app with the mobile link to connect to my kicker snap.  First time I used the app on the apple TV I had the issue that the game did not control resistance so I thought it was the new app.  (I had been previously been running it off my iPad).  I later tried it again and have been using it successfully for the three weeks but tonight the issue came back.  I tried shutting both the mobile link app off and the apple TV app as well as unplugging the kicker Snap all at the same time and restarting but it still did not work.  I then tried the wahoo app and was able to control the resistance so I don’t think it is the problem is coming from the trainer.  Also checked that the firmware on the kicker was up to date.  I also tried running it off the iPad again and that did not work either.  Very frustrating.  Please advise.  


(Chad Folk) #10

Same issue for me, Kickr Snap.  Trainer works fine in the Wahoo App.  In Zwift, resistance does not change on grade changes.  Zwift shows my speed changing on the screen, but my actual cadence and resistance don’t.   I have gone through all the FAQ and trouble shooting tips, but to no avail.  No other apps are running in the background, ect. 

Has anyone been able to solve this issue?

 

I am using iPhone 7.

 

Thanks in advance.


(Mark Miller) #11

Same issue after most recent update. I tried the wahoo update and still no resistance feedback from Zwift. My speed changes going up hill but resistance doesn’t. Very strange. How can I reinstall older version of Zwift?


(Constantine Mastory) #12

Hello All,

The last couple of weeks my kickr snap was working fine with zwift on my laptop (macbook pro). Whether it was a software update or not that made it work, i am not sure. Zwift updated itself and it started working again.
However, if i connect my kickr snap using the zwift link app, the resistance would not work.

Try updating Zwift, give the kickr snap a good old spindown and connect it through your laptop’s Bluetooth and see if it works.


(Patrick Murray) #13

Same problem here. It’s intermittent for me but happens at least 50% of the time. Using ATV for kickr snap. It’s like erg mode is somehow activated when that should not be happening on a normal Zwift ride. Speed drops up the hill, rises down the hill but no cadence or resistance change as if Zwift thinks the kickr snap is an old dumb trainer. Really annoying.


(Patrick Murray) #14

Oh and I always do the normal spindown via wahoo app and then disconnect before launching Zwift and reconnecting. Wahoo firmware is up to date and resistance works in wahoo app so I think it’s a Zwift problem.


(MIke Oldridge) #15

Just found this thread via google search although I was searching for Bkool and wahoo… I’m using Bkool as my training software with a Kickr and i’m having exactly the same problem so not an issue with Zwift I think (or with Bkool I guess). I found today that when I turned off the wahoo fitness app before the start of a bkool ride, things seemed to revert to normal so maybe some issue with the wahoo app interfering with the training software?


(Cam Edmeades) #16

Hi.

I think I’m having the same issue. Feels like I’m going 40kmh in top gear then I got a hill and zwift speed drops but I keep riding at the same speed on the bike. Connecting via Bluetooth from snap to Apple TV.

Yet to try on the iPad yet as it’s old and slow.

Is there an official view from zwift on whether this is a bug or am I doing something wrong?


(Mark Miller) #17

I was able to get my Wahoo Snap to work by the following steps:

-Used Ant+ instead of Bluetooth to search for devices (I think my issue was that Apple only allows up to 3 devices and my mouse and keyboard consumed two of the available slots and something else occupied the third slot)

- Used Wahoo Utility to preform calibration. Then log out of Wahoo apps

-Open Zwift software and search for Kicker under the controllable devices

-Then once it is found open the Zwift companion app.

Not sure which step solved the issue but it worked for me.  Good luck