Struggling to control resistance with Zwift and Wahoo Kickr snap trainer


(Matt Wright (ZHR - C)) #1

I am really struggling to get any resistance on my kickr when using Zwift. The small ring is basically worthless and getting near 200w is nigh on impossible. I do a spindown to calibrate the kickr but then it seems like it defaults to erg mode when using Zwift and i can’t get it back to sim mode. The end result is wasted training session after wasted training session. Unacceptable.

I think Zwift and the Kickr could revolutionize training but I feel there are still a bunch of glitches going on that weren’t ironed out during beta testing. Either that or I am am idiot. Help please…


(Ramon Cuadrado) #2

Matt I am having the same issue, its really frustrating and I can’t figure it out as well. I have adjusted the custom work out however when ERG is on and it set for you to pump out power more than the trainer can handle it locks up and almost feels like I am about to break my chain from the torque.

 

Im on my 4th incomplete ride due to this issue, I am one more ride away from retruning my Wahoo Snap trainer and canceling my subscription.


(Matt Wright (ZHR - C)) #3

Ramon,

i am calling wahoo today and I will let you know what they say. 


(Matt Wright (ZHR - C)) #4

Ramon,

I called wahoo and I’ve got it all working. Here is what I did:

once the trainer is calibrated turn off Bluetooth on your phone  

when choosing the zwift workout make sure you disable erg mode in zwift. To do this just click on the orange circle by erg mode in the chosen workout.

uktimately you don’t want two devices pulling from the trainer so make sure the wahoo fitness app is disabled and/or Bluetooth is always disabled. This worked for me. 


(Mark Robinson) #5

ah I am having this same issue and It only happened since doing this recent update which I did 2 days ago

 


(Mark Robinson) #6

what if you are just riding though and not doing a workout?

can you adjust the erg… It has been working fine in ERG up till now

 


(Matt Wright (ZHR - C)) #7

I like it in sim mode as you don’t want the wahoo app on the phone overriding zwift. When you go to the menu on zwift and choose ‘ride’ it should let you disable erg mode. I have he no problems since turning off Bluetooth on my phone and disabling erg mode in zwift. 


(Mark Robinson) #8

but I am having the problem just riding the course. I am not doing a specific work out at the moment. When just riding the course you have no options to change to or from erg.


(Matt Wright (ZHR - C)) #9

Hit the E button to bring up the workouts then the erg option should be in the bottom center. If that doesn’t work I would so a spin down to recalibrate the Kickr trainer. You have a wahoo right? I would call them. They are very helpful and there is probably an easy fix. 


(Mark Isaak) #10

Ditto on the problem. Thanks for the suggestion. I will disable my bluetooth and try again. three wasted workouts for me.


(L EFTHANDSIDE) #11

Having the same problem in trainerroad with a brand new kickr snap - just wondering whether you managed to fix your problems by turning off all other bluetooth controlling devices (e.g. phones)? My Zwift sim mode works fine


(Mark Isaak) #12

Turning off other bluetooth devices did not solve my problem. I use Zwift for the distraction and view. I use Wahoo’s app to set my resistance for my workouts. I dont want “draft” and I dont care about my results in the virtual world. Sorry if this doesn’t help you.


(Charles Gilbert) #13

I’m having the same problem, I did a FTP test today and when zwift said to power up I couldn’t pedal. The kickr snap was too hard to turn over. This is the second ride and just want to do winter training


(Jack Ross) #14

Ever since the new update I am running into this problem. It is driving me insane, about to drop Zwift.

I have performed multiple spin downs and the Wahoo Kickr adjusts perfectly, as soon as I login to the Zwift world to begin my ride - At times to test it, I will be generating 700 watts and moving 14 mph on flat?

Come on guys you’ve got to fix this.


(L EFTHANDSIDE) #15

Just an update I fixed all my issues by updating yhe kickr snap to beta firmware 2.1.6


(Scott Jones) #16

It seems rather silly to have to disconnect one devise so that a very expensive devise can work properly. I use my Bluetooth to play music through my ear buds because in door training is so much better with music. After a 3000 mile summer I began using my new snap only to think something was wrong with me.


(Scott Jones) #17

Indoor training season has begun here in the Midwest USA and valuable time is being lost. I love the idea behind smart training but think I may go back to old school fluid training


(Edmund Schiffecker) #18

Hello,

I have a Kickr Snap but of I Drive on Zwift, I cannot feel the grade of a track.

I drive for example a ramp with 15% but I feel nothing only the speed will less.

Can anybody help me?


(Tony Maley) #19

im having the same issue. I had a PC break on me  a few weeks back and since then i have gone from finishing top 3/4 in races and being a strong group rider to getting dropped after 4-5k! - i cannot generate enough power to keep up - and like the original poster my gears are all but useless apart from the biggest 3 or 4 which then seems to drive my heart rate up too fast.  I had this issue on the original kickr and last week i upgraded to a new kickr 2017 and but the same issue exists. I dont think my condition has dropped so far in 3 weeks so must be a setup issue.


(J Buchanan) #20

Same issue, look forward to deleting the wahoo apps to see if that will stop issue. BT is on for music different year and it’s a 2017 Kickr some things don’t change I’m sure it’s my BT world, just which one and how?