ZwiftGame Android FAQ (v 1.0.60239)

Hello Android Zwifters!

Hope everyone is doing well and enjoying the December holidays.

We’ve got some details on the latest release and some reminders of how to enable ANT+ on your Android device. For continuity, see the previous update for v 1.0.50775 when we rolled out some ANT-specific features.
ALERT: this release may take a few days to propagate.

Android-specific fixes in release 1.0.60239:

  1. Controllable trainers are now supported over the ANT+ FE-C protocol.
    You must pair POWER first, as FE-C, before the controllable FEC is detected.
    Note 1: we have tested on multiple Trainer types, but please let us know if you encounter problems.
    Note 2: “Road Feel” is not yet supported for trainers with this feature (i.e. Tacx)

  2. We fixed an ANT+ bug where two devices of same type (like two Kickrs next to each other) would cause a ‘no signal’ bug.

Recap of ANT+ supported device types:
Supported:

  • Controllable trainers
  • Bike Power meter (includes Cadence if device broadcasts it)
  • Bike Speed+Cadence two-in-one sensors
  • Bike Speed-only
  • Bike Cadence-only
  • Bike Resistance Control
  • Heart rate monitors
  • Treadmills and run footpods

Not supported:

  • “Road feel”. Currently this is a Tacx feature that does not work in Android.

Recap of ANT+ requirements:
Note 1: If your phone or tablet has native ANT+ you will not need the USB Service, nor an ANT+ dongle.

Note 2: almost all Samsung devices released over the last few years have native ANT+ support. This includes all variants of the Galaxy S6, S7, S8, S9, S10, Note 9, Note 10, Tab S2, S3, S4, S5, S6, etc.

For ANT+ hardware to work with Zwift Android, ensure the ANT+ service apps listed below are installed.

  1. ANT Radio Service

  2. ANT USB Service (only if you are using an ANT+ Dongle)

  3. ANT+ Plugins Service

App Permissions:
When running a freshly installed version of ZwiftGame Android, you will be prompted to enable both your Location and Bluetooth settings.

When taking an in-game screenshot for the first time, you will be prompted to enable camera permissions.

1600×800 229 KB

On Android, Locations permissions give an app the ability to use your Bluetooth radio. Allow this prompt or Zwift will not find your trainer or sensors

1600×800 187 KB

==================================================================

Frequently Asked Questions

Will Zwift run on my Android phone or tablet?
In general, if your device can download the Zwift game app from the Play store, it meets the minimum hardware requirements.

What are the minimum hardware requirements to run Zwift on Android devices?
The minimum requirements are:

  1. arm64-v8a ABI (Arm64 architecture)
  2. 1 GB of RAM minimum. We highly recommend 2+ GB.
  3. OpenGL ES 3.0 or higher
  4. Android 7.0 or higher. [We dropped support for 6.0 on Jan 15, 2020]

Is my Android device supported?
Search for Zwift on the Google Play Store.
If Google says that your device is not supported it means your Android device lacks the necessary hardware. https://play.google.com/store/apps/details?id=com.zwift.zwiftgame&hl=en_US 160

Note: sometimes Zwift will appear downloadable, but is known to NOT work on these devices:

  • Samsung Galaxy Tab S, Tab E, most Tab A variants
  • Samsung Galaxy S5, J7

Why won’t Zwift run if it meets the minimum requirements?
It might run, but perhaps not as well as it had a more powerful graphics processing chip, and more RAM.

Is ANT+ enabled automatically?
As of version 50775, ANT+ is enabled by default.
Note you may still need a ANT+ dongle; check your device specifications!

I get a “Device not Compatible” message in Google Play Store even though the hardware should be compatible.
This may be solved by purging the cache of the Google Play app on your device, then its stored data. This helpful article explains how to solve this issue.

Do I need USB Service if my device has native ANT+ support?
No.

Why won’t ANT+ work on my latest, greatest Android device?

  • Did you install the ANT+ service apps referenced above? You don’t need the USB Service if your device has native ANT+ support.
  • Have you confirmed with the device manufacturer that this model has ANT+ hardware?
  • Is it running a custom ROM? If some key Android components are stripped out of a ROM, it might cause Zwift to run poorly, or not at all.

====================================================================
Thank you for riding Zwift Android, and we sincerely appreciate your feedback!

2 Likes

Good morning,

Is Controllable over ANT+ suggested to be supported for all major brands? I just loaded new update with my Tacx Flux 2- power and cadence view over ANT+ as always but Controllable only shows over Bluetooth (same as before update). I am experiencing an issue as others have where the Controllable Bluetooth signal for Tacx Flux 2 will intermittently show No Signal despite short distance and no interference. I am using a Samsung tablet with native ANT+ support.

Can you confirm testing status of the Tacx Flux 2?

Thank you,

-Richard

Hello Richard,
We tested on Elite, TacX, Saris, and Wahoo brands- but not all trainer variations were tested.
I don’t think we tested specifically on the Tacx Flux 2.

One thing to note: you must pair POWER first, as FEC, before the controllable FEC is detected.
If ANT+ is working for other device types, (like HRM), it should detect FEC.
Try that and let us know, and we’ll update the notes.
Thank you for the report.
Will

Will,

Thank you so much- changing Power to FE-C first allowed everything to connect. Looks like the Tacx Flux 2 can connect. I will let you know if there appear to be any connection or dropout issues via ANT+ once I can get some rides in. (My Tacx Flux 2 with Android Zwift suffers from the Bluetooth dropout on Controllable so this is an exciting development!!)

-Richard

2 Likes

Will,

Just an update- things look great so far. Thanks for you and the teams’ hard work on this!

-Richard

The new update has totally killed the app for us. Using Pixel 4xl with Bluetooth to Saris H3 trainers and heart rate it seems to connect ok but when you hit ride it gives us a jumbled blue screen. Every once in a while one of us can get it to actually start a ride but then the the trainer doesn’t control properly. Both of us have samr set up. Have a screenshot but it won’t let me post it.

Hi, has anyone had any experience of running Zwift on Huawei matebook d 15.6 please

Frank,

Sorry to hear this. Sounds similar to an issue we encountered internally, but need to confirm with logs and screenshot from you.
I will ask CS reach out to you for next steps.
Thank you for the report.
-Will

Tried this with my Pixel C and Wahoo Kickr 18. Worked great, however, it “dropped” after 29 minutes:

Returning in-game to the “pair” screen the sensor would show as connected again instantly, with power readings and cadence etc, but then each time exiting from the "pair’ screen this would be lost again after 2 seconds. Returning again to the pair screen and it would immediately appear connected, and so on.

If this happens similarly again I’ll try to get a video.

Can confirm @Garan_Jenkin’ Statement. Connection Drops around 20-40min after ride start. Going back to pairing screen it reconnects but drops again after some seconds. This happens in a loop.
What gives me hope is that this happens for all sensors at the same time. Cadence, power, heart rate.

Tracy Flux S
Samsung Tab S6
Ant+ FEC

1 Like

I have the same issue of @Garan_Jenkin and @Matt_B3,that is so frustrating and even more if Zwift’s wokers dont response us.

Hi @Matt_B3 @arielir3105

I took the logs from the Android device (small document-like button top-right when on the log-in screen) and have sent them to Zwift as a support case. Perhaps if you are experiencing the same issue you can do the same?

I didn’t have the same issue today, but it was only a 30 min ride. The only difference today was that I didn’t have the companion running on my phone. Probably unrelated. I will try a longer ride in coming days.

For the folks experiencing the random signal drops that stop your avatar from moving and zero watts sensed from the trainer - are pairing via Bluetooth LE or ANT+ FE-C?

I experienced random BLE drops that I couldn’t figure out. What fixed it for me is uninstalling Garmin Connect from my Android device. It was apparently active in the background, and messing with the Bluetooth signal pairing w/ the Zwift app. If you have other apps that actively scan for fitness devices (utilities from Saris, Wahoo, maybe Strava, etc.) try troubleshooting by uninstalling them temporarily. There are ways to disable apps, but uninstalling is a surer way of eliminating them as the culprit.

Garan, unlikely, but it could be related to Zwift Companion. Let us know if you do a longer ride without ZC.
I haven’t seen this particular issue and I have done 45+ minute rides using ANT+ FEC. (no ZC though)
In any case, thank you for your report and encouraging others to send in logs to CS.
-Will

Has there been any solution or explanation for this problem? There’s another thread in this forum about it and it looks like a number of Pixel users are having this issue, myself included.

For what it’s worth, I did an hour + ride on Samsung Tab S5e, connected via ANT+, and had Companion running on my phone (note 9). There were no signal drops. We’ll need to examine logs and do some triage to get a reliable repro case.
-Will