Zwift Trainer Difficulty setting not working on Pixel

I hopped into my trainer and noticed that I was not working as hard or getting the power I normal do on a similar gear during a group ride today. I then checked the trainer difficulty setting and the slider was missing. There was a flat line but, to be clear, the orange adjustment feature was missing. I tried restarting my phone, unplugging my trainer and trying again just in a free ride. Nothing seemed to work… I have used this same set up (wahoo kickr connecting to my Pixel smartphone) for many hours of riding, including everyday of the past week. I am not sure why this happened all of the sudden. I got annoyed and stopped riding for the night. Any suggestions on how to fix this would be greatly appreciated. I just want to ride on!

Are you in workout mode?

Hi, I’ve the very same phone and have been using it for months on my Wahoo Kickr Snap with no issues. Today the resistance didn’t feel right and I checked the settings finding exactly the same as you. Trainer difficulty slider is displayed but no slider to adjust. I switched everything off and tried again still no trainer difficulty. I then ran Zwift off my other Android phone Galaxy 9 I think and Zwift trainer difficulty bar is fully operational and working as it should. Very strange, anybody got any suggestions?

If you have the Zwift game app (not Companion) installed on two devices - is it possible that you’re still logged in on one when you log into the second?

Please save & exit (or trashcan) your first session to fully exit the game. Swiping the app into the background (on mobile devices) doesn’t terminate your session.

1 Like

Hi, thanks for that. I’ve just done as you said and went out with my Google Pixel 2 and ran Zwift, trainer difficulty tab and slider initially worked but after a couple of minutes it’s back to how it was. Trainer difficulty slider is there but the orange tab to adjust the setting isn’t. Switched back on my Samsung Galaxy 9 and trainer difficulty bar and slider working as it should. Its a mystery! I see that a a number of Google Pixel phone users are having the same issue at the moment.

To expand on what @Bob_Gorman_Splunk_65 hinted at above:
Trainer difficultly slider has an effect on resistance only in free ride mode. It’s job is to tweak how steep hill climbs and hill descents feel (if you have a resistance-controllable trainer).

It has no effect on resistance in ERG mode (i.e. when you’re in a Workout and your avatar has a glowing panel in front of the handlebars). Some more information on ERG mode in our Support Hub

Lastly - since you’re using a Pixel: Android devices support controllable trainers if you’re paired over Bluetooth. Support for controllable trainers over ANT+ is not yet supported (real soon, though).

EDIT: As of December 2020 game update, there is support for controllable trainers over the ANT+ FE-C protocol. Please see this thread

Same problem here using a Pixel 3a with a Kickr Snap. Did you solve your problem?

I was finally able to get it to work. I ended up having to uninstall and reinstall the app after shutting my phone down in order to get it to work. Not sure why all of the sudden it stopped though

I should clay because the order might matter: I uninstalled, restarted my phone and then re-downloaded the app. I then connected to my kickr via bluetooth and no longer had the problem

Thanks Joey, I did what you wrote and the slider is back.

I have the same problem.
I have been using Zwift with Tacx Neo 2 for a long time, and still am. I’m using it over bluetooth on a Pixel 3 phone.
But one day recently after a long break, the resistance was basically going to 0 on any kind of downhill, and the trainer was speeding up almost on its own. And I noticed the resistance slider was missing.

I cleared everything, app cache, app data. The slider came back.

But after a few more minutes of riding, the slider is gone again. It’s basically unusable.
And this is in free riding mode.

I have NO other devices connected to the trainer (e.g. a Garmin that could be controlling it. It’s not the case)

Same problem,

No trainer difficulty slider although grey bar and title are there. Resistance feels very low on flat and downhills.

Android 11 pixel 2xl tacx vortex

Beta tester on play store - new features causing problems?

Emailed support to let them know

I have the same issue and also using a Pixel 3a. Uninstalled and reinstalled which resolved it, but it came back again. And again. Bit of a faff to uninstall/reload.

First time I noticed the slider disappeared I was on a flat doing a 90+ cadence when suddenly the resistance went through the roof. I feared for the health of my knees as I came grinding to a halt.

So this needs to be sorted before someone gets injured.

The problem came back!! Back to square one!! Very frustrating, the application is pretty much unusable.

Just got a respond from Zwift Support. They are working on it!

Thanks for reaching out at Zwift support and reporting this issue!
I’ve taken a look at your logs, and your forum posts - thank you for providing us the link and for your contribution to the forum.
This is a now a known bug. I’ve checked with our team and they’re working on a fix.
Although uninstalling and reinstalling the app has worked for some, it may not work for everyone such as yourself.
The fix will come from our end and all you should have to do is keep your Zwift app up to date.
We appreciate your patience and understanding as we continue improving Zwift. Please let us know if there’s anything else that you need assistance with; we’d all be more than happy to help!
Sam W.
Member Experience Agent

This is an issue for me starting in the last few weeks. Any update on why it’s not been fixed yet?

1 Like

I have the same disappearing slider on Note 10+ with Kickr Core. It happened when I went to adjust trainer resistance. I haven’t tried the reinstall restart method as I switched to Apple TV4K (remote hel🏒) but everything works there. I’ll wait for a patch. Thanks to the devs!

This has become a problem for me this week. Running an Elite Suito and a Samsung Tab 7+. Did the uninstall and reinstall and the slider came back until I did a training session in erg mode the following day. Now trying to race or free ride the slider is there in the settings but the orange selector isn’t.
Any news on a fix?

Any update on this fix?
I have just realised I have the same issue after really struggling on my last two rides.
Running elite zumo with pixel 5

This just became a problem for me this week on Pixel 4a 5G. Worked fine until now. I thought it was a game update but…

1 Like