Trainer Difficulty setting reverts to maximum [October 2022]

Same problem for me, using the Android App on a Samsung Galaxy S21 with a Wahoo Kickr V6. Uninstalling and reinstalling the app worked once, but on the next ride the trainer difficulty was locked back at max. Subsequent reinstalls of the app don’t seem to fix anything.

Any word on if there’s been a permanent fix for this? Considering cancelling my Zwift membership as this seems like a pervasive issue for a lot of people and it ruins a lot of the utility of having a smart trainer.

1 Like

Looks like the fix for this has been overwritten in a later release.
Today my trainer difficulty was set to 100% and I didn’t do it. Every time I changed it to 50% it just went back to 100%.
Running zwift on an iPad.
Resolved by shutting down iPad, rebooting and everything ok until the next time.

Hello all,

Thank you for bringing this to our attention. This appears to be a new bug, but we have escalated the issue to our developers and are working on it now.


Same problem. Started a few days ago

Gald im not the only one…shock to the legs from 30 percent. I juat thought i was having an off day. :slight_smile:

Please add me to the list of victims of this bug. Wahoo Kickr bike 1 with latest firmware. Latest Zwift client running on Pixel 4 XL with Android 13, paired via Bluetooth.

For me the same issue on a Galaxy Tab S7. After I reinstalled Zwift the trainer difficulty set was on 50 % but when I started my ride it’s set back to max.
Please solve this issue

Having the same issue, Elite Optima Turbo, Samsung Galaxy S21 Ultra Zwift mobile app fully updated

Worked fine on a ride today.
As an experiment I borrowed my wifes phone and Kickr bike, and rode on that. The trainer difficulty behaved itself. I then logged off her phone, and opened my own phone and bike again as normal. Trainer difficulty stayed working properly. Does that help anybody else ?

Hello everyone,

I want to elevate @Andy_C4’s recommendation as a workaround for this issue, as trainer difficulty seems to only be getting stuck at maximum on some devices.

If possible, please attempt to:

  • Log into your account on another device
  • Adjust your trainer difficulty settings to your preferred level
  • Save the settings and log out
  • Return to your preferred device and log in

Just a vague thought … it was this settings screen where you added a new field recently related to the holo-rider. Might this bug be related to whether a person had made changes in that screen since the new variable was added ? (I used to be a software engineer before retiring !) I had changed things in that screen, but my wife had not. Mine broke, hers was fine. Might be a red-herring of course.

Nope not working…:disappointed_relieved: hope the see a fix soon, steep hills are to heavy with my mounted cassette​:hot_face:

This issue was discovered too late to have a fix in 1.31.0.

I know this isn’t the greatest workaround, but if you choose to ride hills while doing a workout in ERG mode, that should negate the issues regarding trainer difficulty.

Hello Rowdy

This solutions doesn’t work. So please fix this for us

Yes trainer difficulty set on maximum using whoo kick r running on tablet samsung galaxy s8

Hi Rowdy, you guys acknowledged this problem over 2 weeks ago and if i understand you correctly people dealing with this problem (like myself) have to wait another 2 weeks or so untill the next update or is there any chance this gets fixed earlier?
Would be decent if you at least wouldn’t let me pay for the weeks i’m unable to use Zwift…

I have the same issue : trainer difficulty aleays to 100 per cent, using Wahoo Kicker and Samsung Galaxy S10 plus…

It’s now Sunday. It’s not yet solved. Nice group ride with the trainer difficulty in max. :-1::hot_face::rage:

Hello again all,

I want to update that the fix will be in an upcoming release.

If you have just encountered this issue for the first time, please uninstall Zwift, restart your device, then reinstall Zwift. If you continue to have problems, please reach out to us directly.

When will that update come? This bug has been present for several weeks already.