When paired via bluetooth, Saris Trainers cannot complete spindown through Zwift/report resistance issues

APRIL 24, 2020 UPDATE:

  • Saris H2, H3, and Magnus trainer spindowns will now work in-game with latest beta firmware from Saris. Please note the firmware is a beta version and is available via the Saris app (Menu -> About -> Advanced Firmware Options).

is this just for ERG mode? i just did a regular “free ride” and the resistance was really weird over grade changes. it was like there was a 20 second delay on all the grade changes.

i’m on a kickr snap 2017, latest firmware.


Thanks for that info, Dan.

We’ve heard more reports of this in ERG mode, but this could be related. If you haven’t already, could you open a support inquiry and send us any logs? Thanks!

+1. No control in ERG mode in workouts since the new update.
Apple TV, kickr1. Can’t complete a spindown. All latest software.
Works fine in wahoo’s native spindown app. Works fine in Fulgaz.

Also tried in iOS app and Macbook. No joy there either. Macbook keeps saying “no signal” when searching for the kickr.
iOS app exibits the same ERG mode issues as Apple TV4K.


Same Here. Kickr 1 latest firmware version. Everything working fine at Wahoo Fitness app.
No Resistance on grade changes. ERG mode not working.
Already got in touch with support team. Waiting for a solution as it is a known issue.


Same problem - Hammer 1 - Apple TV. Everything updated, works fine in native app

opened a support ticket with logs! hope it helps!

Same problem with Élite Drivo. Ticket opened

1 Like

Same issue. Hammer 1 / MacBook w ANT+ & BLT. Tried iPhone as well

emailed Zwift support and they said to update firmware.

Firmware is, and has been, up-to-date.

UPDATE: appears to be limited to Bluetooth - forced an ANT+ connection by turning off Bluetooth and it worked fine again

Same happened to me today! 2018 Kickr Core. MacOS.

Hi, problems with the resistance aswell, even in free ride.
My trainer is Elite Qubo Digital B+ paired with iPad 2017.
Hope it gets solved asap. Rainy and windy out there for the next days :frowning:


I’m having the same issue in both ERG mode and during free rides. In free rides essentially every course becomes flat - no resistance during climbs. Only the BLE connection seems to fail. Using ANT+ there’s no problem, just have to give up cadence or HR data in that case. Using iMac desktop and Cycleops Magnus.

Ticket opened yesterday with Zwift support.

1 Like


I am having the same issue with BLE/IOS with my CycleOps Magnus M2 since the update. Opened a ticket. Hoping for a quick fix. Thanks!



I have been having same issues since the desert flats update. I just done another hour ride. Same issues as everyone else. I tried have found using the bluetooth from the companion app gives better results. Was failing before the 40 minute mark but at 40 minutes the spindown worked.

Long as I followed the numbers on the companion dashboard things were working as normal for last 25 minutes. laptop screen was so far behind.

I have opened support ticket and sent logs. sending logs again from this ride to show the difference.

1 Like

Same issue here

Apple TV
kickr gen 1

No spindown
No resistance change


I have an ant+ dongle I might give that a go.

Count me in on this bug as well; I wasn’t in ERG mode but rather was doing a free ride on the Greatest London Flat this morning when I realized my trainer’s resistance wasn’t changing at all to reflect the posted elevation. I’m on a CycleOps Hammer, latest firmware; tried to recalibrate and it failed in Zwift but succeeded in Rouvy.

I also filed a ticket, but figured I’d add my voice to the chorus here too. :wink:


Same problem: ERG mode doesn’t work in workout mode and no up-slope/down-hill resistance in free ride; spin down could not complete and stuck at 2 mph every trial. Using app on iPad and Cycleops Hammer with everything up-to-date. Everything was working fine before updating the Zwift app on Friday.


Mine too ! Latest update on Apple TV renders the app unusable.

Calibration is way off.

And won’t complete a calibration.

Yet when the same setup is connected to an iPad without the update. It works and calibrates fine.

I’m just stuck on a tiny screen rather than my two dedicated 40" screens :man_facepalming:t3:

Sort of out Zwift !:rage:

Also with cyclops hammer no resistance in free ride.