Saris h3 calibration

Hi there,

I recently set up my saris h3. I have tried calibrating using Rouvy, Zwift and the saris app. Despite pedalling like fury, it seems like I could pedal forever and never complete calibration. Anyone else had issues?

I am using iPad and iPhone.

I had it once using Saris App on iphone; forced quit the app and worked second time.

Zwift process never worked when I tried it.

Use the Saris app on the IPhone and make sure firmware is up-to-date first before calibrating. The Zwift calibration has never worked for me. For some reason can never get up to the speed expected by the Zwift app.

I recently had trouble with this and my new iphone was the culprit. I had to allow the app to use location services. Saris recommended changing this setting and it worked afterwards. Also I second checking your firmware. Make sure you are starting fresh with nothing else running, like Zwift. I have tried to update my wifes trainer for over a year and it never says it needs an update. This weekend there was multiple updates dating back 2 years.

I will give this a go. I did update firmware, so that’s a non issue

Firmware is updated. I’ll double check location services and close everything out on the phone. I have a lot of other Bluetooth devices on the phone that I’m hoping are not interfering. I don’t want to uninstall them.

A few weeks ago I found it wasn’t my iPhone 7+ connecting to other Bluetooth devices like a headset but other computers and tablets in my home office trying to connect to the trainer sensors and HR monitor. So Bluetooth is turned off on those systems before I connect to my iPhone with Zwift Companion and AppleTV for Zwift.