Saris H3 and Calibration issues

Will my new Saris H3, I cant get this thing calibrated… I have the latest firmware updated with the Powertap app.

When I open the Saris Utility app, the app never actually finds my trainer, rendering this app useless to me. I have had no issues connected my trainer to Zwift or any other app. The calibration feature on Zwift also does not work. I have a macbook, and there doesnt even seem to be a way to calibrate with Rouvy which I see others recommending…

Anyone out there have similar issues?!

Similar issues. I could never calibrate in Zwift. Once up to speed, Zwift just kept messaging to “maintain current speed”. After 5 minutes of doing that with no result, I gave up and moved on to the Saris app.

I was able to calibrate using the Saris app, but my ride immediately following in Zwift had my speed at 60+ mph.

No option to calibrate in Rouvy either, but my calibration from the Saris app seems to have transferred much more accurately to Rouvy in terms of speed.

3 Likes

I have the same exact issue. I am told to maintain current speed forever.

Well I was able to get everything working again once I was able to update to the latest Saris app, the newest version allowed me to connect to the app and get it calibrated. The Zwift app still does not work though, but at least something worked.

Same w me. Latest version of saris app allows me to calibrate but calibration and speed are suspect when in zwift with speeds approaching 50 mph on downhills (I’m just not that fast). I’m not able to calibrate the H3 using the Zwift app. I have the same problem as others in this group: it tells me to maintain my speed but it never stops asking me to maintain speed and I have to abandon the calibration effort.

Yesterday I was unable to calibrate my Saris H3 with the Saris app. Calibration would run but the spindown when you coast would never finish. I eventually just canceled it I tried three separate times and it did this each time.

Eventually I tried calibrating with Zwift which seemed to work, for the first time in a really long time, but the calibration seemed off. Watts were eratic.

Hi Everyone - has there been any resolution to this issue?
I just got the H3 a couple of weeks ago. I was able to update the firmware and calibrate with no issues using the Saris app on my android device.
That said, when logging into Zwift, I started running into issues. I was able to pair everything via bluetooth with my windows pc. When calibrating, the instructions don’t make sense, says to speed up to 37kph and then let it coast to 0 - once I get to 37, it says to maintain speed and keep pedaling but to no end!! After trying this 5 times, I just decided to speed up - once I hit 50kph, it says to stop pedaling and let it coast to 0. then it says calibration successful. FINALLY!!
However, I ride with a lot of people who don’t have the H3 - they have the wahoo or tacx or others - and I can’t keep up. I feel like my speed/watts are not being accurately reflected and they just seem to pull away. I’ve tried tinkering with the trainer difficulty and even went through the entire calibration in Zwift again using ant+ instead of bluetooth… But still to the same result.

I’m starting to question my physical abilities even though I know the riders I ride with are the same strength/level as me. This is very frustrating as every ride I try to do with friends, I get dropped (like 1min behind not signal loss) within first 5min of riding.

Any solutions???