Running Calibration crashes the client app

Hi, Windows, SARIS hammer 3, tried three times this morning to calibrate. Each time, I got the speed to 32kph or more, then the UI crashed. Not a showstopper, but it worked before Xmas.

Hi @Trevor_Holdsworth_AS

I assume you are using Bluetooth there is a bug.

Use the Saris app to calibrate or ant+

It worked for me up until the last update.
Any idea when it will be fixed?

Same here on Mac with the SARIS H3. Happens only after the most recent update. Calibrated on Saris app fine, but not as convenient.

Almost exactly the same situation for me. I have a Saris H2, and the Zwift desktop app (Windows) now crashes when I try to calibrate every time (happens when I hit or get pretty close to the target speed for calibration spin down). I’ve never had that happen before ever, but it started this past week.

Same here. Latest Zwift update broke bluetooth based Saris calibration. iOS. macOS. tvOS. All broken.

Hi @Christopher_Solomon and @Franklin_Templeton

Please use the Saris app for calibration. There is a bug that Zwift is working on for the Bluetooth calibration. ANT+ calibration on windows is fine.

Even when I use the Saris app for calibration on iOS, it will crash the Zwift app if it’s running at the same time on tvOS or macOS.

Calibrate using Saris then open Zwift.

I don’t think it will crash Zwift but the connection will be dropped because Bluetooth can only link to one device.

From what I can tell Zwift seems to use my previous calibration when connected to my Saris on Bluetooth. So if I calibrate from the Saris app and then continue with my Zwift ride the power measurement is off.
That doesn’t seem to happen when I connect to the Saris using a Ant dongle though. The Zwift app doesn’t show the icon to recalibrate when connected on Ant. So for now my solution is to use the Ant dongle with Zwift, and then calibrate with the Saris app on my phone.

Zwift just released a new build today and the release notes did not include any mention of this issue. Is the Zwift development team aware of this bug?

The calibration data (whether you use Zwift or the trainer app to do it) is stored in the trainer, not in Zwift. The trainer uses that calibration data to tell Zwift what power you are generating.

Hi I’ve got the same problem. Is there anyone who found out a solution

Same here. Crash occurs on a Saris H3 on Windows and on Android app. Crash happens as I bring the trainer up to speed. 100% repro rate.

Firmware on the Saris is latest stable.

Same here, my zwift app crashes when I am calibrating my saris h3. (when I’m about to reach 23mph during calibration, all of a sudden the app crash/close by itself).
I’m also using laptop that runs windows 10 OS.

Please resolve this bug issue.

Don’t use Zwift to calibrate your trainer, use the Saris app. This is what Zwift themselves recommend - the manufacturer’s app is always the best option for calibration.

Hi, I have always been able to calibrate my smart using Zwift but here recently, every time I try to calibrate and get to almost the top speed the program crashes…everytime! I have tried dozens of times over the last 2 weeks. However, I am still able to calibrate using the Saris app. My trainer is a Saris M2.

Is anyone else having this issue?

Thanks!

For what it’s worth, if the trainer has it’s own app to do the calibration you should always use that instead of the Zwift calibration.

1 Like

There is no reason you need to calibrate in Zwift, just use the Saris app.

Why is there an option to calibrate from within Zwift if you cannot use it? Why is it better to use an outside app? Seems kinda crazy to me, maybe Zwift is going to completely remove the calibration option…

You can calibrate using ANT+ that still works. The calibration in Bluetooth has a bug that they are working on.

It is always better to use the manufacturer app than Zwift. They will implement updates and changes in their own app before letting Zwift know.