Resistance issues after update

Resistance control worked fine once I switched from Bluetooth to Ant+.

Same issue with Windows 10 and Wahoo Kickr. I use ZCA as a Bluetooth bridge, because I just can’t get Ant+ to work adequately.

Why, ANT+ is far superior than BlueTooth in my opinion.

1 Like

I too have the same issue. CycleOps Hammer provides no control feedback. This sucks as it is happening right in the middle of the Le’Etape du Tour.

Please fix soon!

1 Like

Same issue with my H2. Recalibrated in Rouvy to no effect in Zwift, works fine in Rouvy. Sent a ticket, now awaiting a fix in the next update.

1 Like

Have the same problem. Cycleops Hammer and IOS. Logged a ticket and got this reply:
hanks for contacting us at Zwift Support!

I’m sorry that ERG mode isn’t working on your trainer in Zwift.

I’m sorry to say, but there’s a recent known issue of lack of resistance in ERG mode​​ for some smart trainers. Our team is looking into this for a fix as efficiently as possible, as we’re sorry for the frustration this may have caused.

In the meantime, it can help to check that the firmware on your trainer is updated​​​, and that you’re not experiencing Bluetooth interference​​.

We have discovered this is a bug, if the steps above do not help, we are currently working on a fix, so make sure to keep your game updated! We released an update for Mac last night, so an update for other platforms is coming soon! (Not change for AppleTv or iPad for me so far though)

I hope this information helps shed light on the situation. You’re more than welcome to reach back out to us if you have any other questions.

I submitted a support ticket and got a reply right away. They are working on the problem. Check for any app updates! In the meantime jam to the new catchy tune!

With ANT+, my wattage briefly drops to 0 about 2 or 3 times an hour. According to, my ANT+ signal is “going up and down like a fiddler’s elbow” (or something like that). I have tried all of the recommendations I could find online to improve on that signal. I’ve tried two different ANT+ dongles (from different manufacturers). I’ve tried two different USB extension cables (from different manufacturers). I’ve tried different placements of the dongle: at the handlebars where a head unit would be, under the bottom bracket, in front, to the side, and behind the bike. I’ve tried the USB3 ports on the front of the PC, the USB3 ports on the back of the PC, and the USB2 ports on the back of the PC. I’ve tried setting my WiFi channel to 1, 6, and 11. (I’m in the basement, so I don’t really have to worry about neighbors’ WiFi.) None of these steps have helped. The ANT+ signal is always terrible.

On the other hand, Bluetooth via ZCA works like a charm–or, at least, it has in the past. The beta Windows 10 native Bluetooth implementation was never able to control my trainer, and now it looks like Zwift may have propagated the beta Windows 10 native Bluetooth bug into the ZCA Bluetooth implementation. So sad.

Most of the time, though, I’m doing TrainerRoad workouts while Zwifting, and I let TrainerRoad control the trainer. That’s why it’s taken me this long to notice the issue.

1 Like

Wow @Jim_Mattson It sound like you tried everything possible to make ANT+ work. And that is why indoor trainers should have a USB port. What is the point of wireless if you need to run a wire and place it next to the trainer. :frowning:

It sound like Zwift is on top of this problem, I hope they get it fixed soon.

Good luck.

1 Like

I was ready to launch my trainer at my iPad. They will fix it in due time !

Ugh! Thanks everyone for this post. My “no resistance” “no change” issue is not happening in ERG mode. Just regular ride mode. I hope Zwift will add this to their “Known issues” link on support soon. I spent HOURS trying to troubleshoot it. I’ve lost days of training now =( Does anyone know how uninstall this update?

In the meantime I will try and find and ANT dongle for the IPad?

Qubo Elite Digital B+
Apple IPad Pro

It feels like piling on, but I’m in the same boat. I run Zwift on an iPad and I noticed during my Zwift workout routines yesterday and today that Zwift seemed to have trouble changing power levels. I tried multiple spindowns in Zwift but all attempts failed. Having a KICKR, I tried a spindown using Wahoo’s app and the calibration was successful. I then tried more spindowns in Zwift but all failed. I wondered if this could be tied to the update with Fuego Flats and this thread confirms my suspicion.

For what it matters, I just submitted a message to the support center.

Kinetic R1 T-7000 has one :slight_smile:

Same issue.

Wahoo Kickr 1st Generation
BLE connection via IPad Pro 11”…most recent one.
Alternate connection directly to iPhone 7 attempted.
Same result on both. Kickr is not recognized by zwift as controllable.
It’s only read as if it was a power meter.

No issues prior to most recent update.


Yesterday Stage 4, there were delays (~20s) in resistance setting, then 7km to the end resistance was lost. Inpeak Powercrank PWR, Elite Nero CTRL, iPad.

I am having this issue with Cycelops M2, Apple TV, and bluetooth connection. Suddenly this week there are no resistance changes based on terrain. Very frustrating during a tour stage yesterday. No issues previously. What changed?

The latest update,
See this post. and multiple others. Zwift is working on a fix

1 Like

Almost exactly the same set up and issues with me. The KICKR will link as controllable but will not alter resistance in free ride (SIM mode) or Training (ERG Mode). Again all was good until a few days ago…

I have 2 cycleops hammers, one only a 2 weeks old. Both keep flashing blue with no resistance changes.
Very disappointing. Seems to have occurred after zwift update several days ago. Hope there is a fix soon.

Same here. H2 and Apple tv no control.