Resistance issues after update

Like many have reported, I am now experiencing issues with resistance after latest update. Changes in incline make no difference to resistance and erg mode in workouts doesn’t work. Using Apple TV and Cycleops Hammer (firmware up to date and calibrated). Others have reported problems with other trainers and ios devices and bluetooth.

This really shouldn’t happen.

Multi million dollars in income from our subscriptions and it appears they gave the update job to the newbie.

I won’t bother submitting a support ticket - I hardly ever get a response.

Same issue here. BLE from Mac OS won’t control trainer resistance. For example I came off the Radio Tower descent yesterday and had to push 300w in a very easy gear - 53/23… Using a Tacx Neo but it won’t coast at all on steep descents when in BLE. I switch to ANT+ and all works normally but I am staying in a accommodation with no access to the wireless router which is running Channel 10 so ANT+ drops continuously.

I hope Zwift fixes this soon…

Same issue when I logged on to Zwift this weekend, I’m using a cycleops H2 on a Mac, Zwift reads the power but no control of resistance in erg or slope mode. Not great! Other apps (Sufferfest) are working without an issue.

1 Like

Same issue after update.
Kickr gen 1
BLE connection.

Grades not simulating, erg mode not engaging, and spin down failing.

Please fix this soon.

1 Like

Absolutely same thing is happening to me and I’m ready to cry, this is all becoming sooooo frustrating. Wish I could tell you that this has been the only performance issue I’ve dealt with since I subscribed to Zwift in November 2018. For what it’s worth, I will submit a ticket.


Same here Apple TV with hammer h2 no resistance any news on a fix

1 Like

Oh good. I’m not alone. Same problem. No resistance control from Zwift on Hammer—the blue connectivity light just flashes; doesn’t go steady.
I see the bias go up on workouts as I hit the + but no change in resistance.
Rouvy does control the resistance OK. So it’s a Zwift issue I think.
Thanks, all. I still love Zwift!

1 Like

Spent over an hour troubleshooting. Decided to come and check the forum and glad I found this thread. I have no resistance change running iOS with magnus trainer. Firmware up to date and calibrated through Rouvy. Setup worked fine prior to update. Rouvy has no issue controlling the Magnus. Zwift is not. Very disappointed. Maybe Trainer Road time🤭

Same issue here, since update. I’m using cyclops hammer, firmware up to date, appletv. FullGaz worked fine

Same issue here. Trainer talks to Zwift, but Zwift cant talk back no change in resistance. Ridiculous!! Brand new H2 trainer-- First time never used Zwift before-- Paid my subscription and an immediate problem

1 Like

Not to just pile on or anything… but I am on an Elite Qubo Digital Smart trainer and AppleTV with no change in resistance while riding. I can connect fine, power inputs into Zwift okay, so does cadence, HR, etc. but no change in resistance while riding. I was checking out Fuego Flats and didn’t think anything of it until I began ascending out of the desert. Any news? Here for the update when they fix it.

1 Like

Same issue magnus 2. Rouvy calibration was successful. No issues there. Recycled the power and now three days running no resistance. I’m not seeing any zwift comments. Makes me worried they’re not looking into it. Joined in dec and have had periodic buggy things but nothing like this. Rides are crazy boring without hill resistance adjustments.

Same issue with iPad and Elite Nero. Reloadin Zwift app sometimes resolves problem.

Just launched Zwift for Mac and an update ran. Tried BLE and issue appears to have been resolved. Resistance and coasting worked fine…

Same issue with iPad and elite rampa but after reloading many times the app, the problem is not still solved. The race continue to works without resistance. I’ve not still find the update on App Store

Resistance control worked fine once I switched from Bluetooth to Ant+.

Same issue with Windows 10 and Wahoo Kickr. I use ZCA as a Bluetooth bridge, because I just can’t get Ant+ to work adequately.

Why, ANT+ is far superior than BlueTooth in my opinion.

1 Like

I too have the same issue. CycleOps Hammer provides no control feedback. This sucks as it is happening right in the middle of the Le’Etape du Tour.

Please fix soon!

1 Like

Same issue with my H2. Recalibrated in Rouvy to no effect in Zwift, works fine in Rouvy. Sent a ticket, now awaiting a fix in the next update.

1 Like