Resistance drop during ERG mode workouts

When using ERG mode during a workout, the resistance on my trainer (wahoo kickr) all of a sudden drops and I’m easy pedaling, but zwift still says I’m doing the target wattage (for instance, i’ll be soft pedaling but zwift says I’m putting out 300 watts when I’m definitely not). I’m using the bluetooth connection without an ant stick. Possible connection issue?

Has anyone else experienced this and/or have a fix?

Did this just start happening after the recent update?

I’m having issues with ERG mode not adjusting resistance during interval workouts. It just stays flat instead of auto-adjusting to the interval wattage.

Can you provide a bit more info. how do you pair your trainer.

see this: Guide to Getting Useful Support?

Elite Direto to Macbook Air. Have tried ant+ and BLE connections. Neither work correclty.

Can you put your log files in and look at the network and sensor dropouts.


Started about 2 weeks ago after the update a few days prior


I use just the wahoo kickr on a bluetooth connection to my laptop with the zwift program running. No ant stick. Possibly a signal error?

have you looked at your log file in

I’ll have to wait until I get home to do that. But it’s not a sensor or network issue.

All of the equipment connects and works consistently. The only issue is in ERG mode. Zwift does not automatically adjust the tension when a workout changes from one zone to another. I’ve had to manually adjust it with the up and down arrows in the companion app.

Do you pair the trainer as ant+ FE-c.

Did you try to disable and enable erg during the workout?

Yes to both.

Have tried ant+ (FE-C) and BLE. Toggled ERG on and off and also calibrated the trainer this morning. Still not working properly.

I noticed I had an iOS update pending. So I downloaded that and will try again tomorrow.