My trainer takes a long time to follow the ERG setting

I follow a training schedule on zwift. For wich I use ERG mode. When the watts rise or drop, it takes a long time before the trainer adjusts those watts. Therefore I can’t do the sprint correctly, or get back to normal watts because the trainer stays on 600W. Does anyone know what I can do to change this?

We will need more info like what trainer and how you pair. What device are you using.

Wahoo kicker core. I use my laptop to ride on zwift.

I use a kickr core too, connected with ant+, and it works fine with erg mode. How are you connecting it? Define a “long time”, how many seconds?

1 Like

easely 2 minutes

Wow how do you pair the trainer. :flushed:

1 Like

Something is very wrong, either the pairing is incorrect or the trainer is bad.

1 Like

I have the Kickr 18 model with latest firmware, same issue with me (connecting with BLE) the watts were way off target watts on ERG mode, regardless how much I spin there was no change to output power.

Tried calibrating again via Wahoo app, no change. Then tried again this time via Zwift app which seemed to fix the issue, however, a few workouts later the same issue emerged again. Contacted Zwift support who advised to calibrate again via Wahoo app.

Seemed to be working initially but when there is quick changes to workout blocks, the same issue arises. Worthwhile trying the ANT connector?