Zwift Play - Android connection Issues

I have tried this on two different android devices now and the same thing happened.

I load zwift and everything other than steering pairs as it should.

I then click on steering, the zwift play controllers both appear, i select both of then them when i go back to the pairing screen the tile is still orange and only one has the green dot next to it.

go back in to the pairing tile, unselect them, they both disappear, then reappear, select them both and the same happens. The blue Z logo on the device is solid blue (not flashing) so the controllers look like they are paired but they do not work.

when i load the game it says steering is on but the controllers don’t do anything.

Video of the pairing issue here:

it has happened on two different devices so don’t think it is my android device that is the issue.

I have failed to make these work with v1.0.0 firmware on an Android Google Pixel 4 phone (that works with everything else Bluetooth). Same experience as you. I tried with my wifes Samsung S20 and they did pair, but then disconnected again within a minute. Totally unusable as-is, and unless the v1.1.0 firmware improves things drastically they will be returned as not fit for purpose (unfortunately).

v1.1.0 did not fix it for Android. Worked once for Repack Rush, but totally unreliable. Unfortunately cannot recommend these products as yet, and mine will be returned.

1 Like

I got the update after i finished riding today, will try tomorrow but doesn’t sound hopeful

Today, 3 times crashing Zwift with zwift play, without no problem…

Fw 1.1.0
Samsung tab s7

Hope next update will be better with no Zwift crashes, very bad and not fun till end of a race

I tried a third android device today, same as above.

Has anyone actually got them to work on an android device yet?

I got the same connetion problems and while waiting for connecting game crashed 4-5 times on Galaxy Tab S8 Ultra 5G
I switched to phone, Galaxy S23 Ultra 5G, game crashed 2 times and third time it worked. I did a 50min activity with no issue.
Hope Zwift is working on this.

Zwift Play firmware 1.1
Android 13

Tried again today, after a lot of pairing and unpairing i got them to pair and then the game immediately crashed. tried again and same thing.

Either they don’t pair correctly and the game doesn’t crash or they pair and then the game crashes.

I would very much avoid these for now if you use android to run the zwift game.

Tried them second time, on android tablet and phone:

  • issues while establishing connection, some times it worked pairing them separately
  • crashes while establishing connection, application just closes when second controller connects
  • after establishing connection and starting game, application crashes after a while. On tablet I had 5 crashes during 1 hour, on phone application crashed 1 time during 1 hour. Starting after crash, zwift continued previous activity.

I will not use them again unless a software update or firmware update.

1 Like

I’ve given this a try myself.

They show up on pairing but when you connect to them and go back to pairing screen the icon remains orange and says connecting.

If you go back in and try again the program terminates completely.

Tried again and despite them saying connecting i went to Repack Rush and for 5 seconds i had steering, then the steering on icon disappeared.
Went into pairing screen and unpaired and tried to repair at which point the program terminated.

Fair to say they aren’t working as they should.

1 Like

yeah, i think they’re best avoided for now if android is your main zwift device

Has anyone used Android to pair turbo and hrm via ANT+, only pairing Zwift Play through Bluetooth, all through the Android Zwift app?

That would be planned way of adding Zwift Play, as the Mi A2 mobile I usually use has ANT+ functionality after downloading plugins, in adition to supporting two Bluetooth devices.

I tried unpairing everything and pairing the play controllers and it just crashed every time so not sure it would work.

I could try later but wouldn’t be too optimistic

1 Like

I found it easier to connect on Android if you first connect the right controller and close. Then go in again and connect the left controller. Close and wait a second for it to turn blue.
It seems the order right-left is important right now…

1 Like

I tried every combination, mine just immediately crashes.

tried everything else paired via ant+ and still the same, just crashes continuously

I would definitely hold fire on these if you’re using android until these issues are resolved.

1 Like

Yes. I must admit that twice - after connecting as I described - it crashed after approx 10 min or so…
So we look forward to the next update, yes…


I use mine mainly on PC and they work perfectly.

I will continue to check android (i have 3 devices i can check on) with each update and try to keep this updated with any progress.

Just putting this here for visibility too

1 Like

Hi folks,

Thank you for linking the other thread, @Chris_Holton. Indeed, the crash that occurs on Android when paired to Zwift Play will be fixed in the next Zwift version.

Based on your screenshot, you may also be running into an unrelated issue where a Play controller (in your case, the righthand controller) is not fully connected. If you fully power down the controller, then power it back on to pair, it should pair fully and show the correct battery level.

1 Like

What about ATV, last 2 rides zwift play crashed after about 10 minutes. Connecting through companion app. Would reconnect to power but no erg mode. HR and zwift play would not reconnect. Had to restart Zwift and pair through Apple TV directly and could not then use Zwift play.