Zwift Play connection and crashes - PC, Android [June 2023]

I just got a Zwift Play. Running zwift on pc. Very stable - can’t recall the last time I had a crash until now. Devices all usually connected by ANT+ without issue

Sequence of events

  • loaded zwift, connected to new play controllers without obvious issue (via the PC’s BT)

  • started repack rush. Left controller and steering fine but right controller very intermittent and then seemed to lose connection. A little while after, zwift crashed. Had to kill the app.

  • reloaded zwift, connected ok but again no response in game from right controller - rode an event rather than repack this time. Restarted right controller and game crashed.

  • suspected that the connection was causing the crash so connected play controllers via companion app. Tried repack again. Intermittent on right still at start but then seemed to get better and worked properly. Used for about 15 mins with no further issues.

So in short, I seem to have a connection problem with the right controller that triggers crashes. On the face of it, connecting via the companion seemed to eventually fix it but does mean I can’t then use ANT+ for my other devices as companion seemed to grab them via BT.

I suggest contacting Zwift support.

My right shifter got disconnected also a couple of times. Also running zwift on a PC and making use of the built in bluetooth adapter. I will try to pair the controller through my ipad on my next ride.


Supposedly new Play firmware releasing on June 20. Might or might not help.

1 Like

Power the controller off and then back on. Worked for me this morning.

Having the same issues with Android (Google Pixel 4 phone). Not stable enough to be usable right now.

1 Like

I’ve only just got my play controller. Two rides out of two the left controller stopped working after about 15 minutes. I’m on a PC with BT dongle. First ride, after it stopped working, went into paring, unpaired it (it was still showing paired), then re-paired, and it was working again. Second ride (next day), it stopped after similar time. Thought I’d try just turning it off and back on again while continuing to ride - not a good idea, as that froze Zwift and I lost my ride.

1 Like

Windows can be set up to turn off USB ports that it doesn’t think are being used to save power (such as if you are not activly using the Zwift controller). Can you check that the USB port that your dongle is connected to isn’t set to power off? In the start menu search bar type ‘Device Manager’. Under the USB section you’ll find all the USB hubs and stuff that Windows thinks your machine has. If you right click and the select properties on these, some of them will have a ‘Power Management’ tab where you can set whether Windows is allowed to turn off the USB hub to save power. Have a look and see whether any of yours are set to power off. (Apologies about not being more specific, without being able to see your machine and what your dongle might be called I’m not sure if you can more easily pinpoint which of the USB entries specifically to look at - so just go through them all).

1 Like

I have the same issue with the right controller playing up and crashing however if I apply power to the controller and use it, it’s absolutely fine and no crashes…

Same here, right Controller (Bluetooth) crashes Zwift on Android in some situations, my solution for today was to pair the right first an then in Zwift-Game the left, that works for the rest (30min) of my workout…

Similar here on first use - right controller lost connection- restarted and zwift froze 13 minutes into the session

4 or so rides and no issues. Using ANT+ and not Bluetoot. Maybe Bluetoot issues?

I was having this same issue, except this morning, both controllers kept dropping in and out during a race. I’m on an apple m2 processor, ant+ for my elite suito and Polar h10, bluetooth for the play controllers. After the race i repaired using the companion app and the controllers immediately connected and no longer dropped out. I had tried connecting my apple tv through the companion app first but it would not recognize my Polar h10. switching to my laptop plus companion app pairing seems to work for me.

These are great when they work and stay connected. I’m trying to stay patient, realizing this is all still in beta and we are here to try to help work out the bugs.

Firmware update…

There is one or you think that’s the solution?

Found this thread - looks like firmware 1.1 is out but being rolled out progressively until Friday - using the companion app I can see I’m on 1.0 and the new version isn’t available to me yet



There is one. I got a pop-op in the Companion app telling me of an update.

2nd time using them today and within the first 30 minutes of riding the right hand controller stopped working 5 times. Each time I had to turn off and back on to get it to function. The left hand one continued to work the whole time. It never lost pairing, just stopped responding.

2nd 30 minutes no issues. Would be annoying in an event. Was just robopacing and teleporting.

Battery on both at 60%

1 Like

There is an update rolling out. You will get a pop up in the Companion app when it is available to you.

On which platform are you running Zwift?