Right Zwift Play not responding

Hi, I have noticed that each time I am using Zwift controllers right one is getting disconnected after few minutes - sometimes right away, sometimes after 10, 29 minutes (or so I notice). In the device section it looks like connected all the time, I can reconnect it, but after a while it is disconnected again. I am connecting directly to my PC, without using companion.
I was wondering if anyone has the same issue and if there is any workaround for that or maybe it is known issue.

Yes, it’s accepted that the Play are not working as they should with Windows.

A fix is on its way.

what bluetooth controller are you using?

I had this happen to me on Windows today, too. I just powered the right controller off and on again and it stayed working for the rest of my ride.

I just got my Play set up last week and I am experiencing this same issue.

But for me it is almost exactly 5 minutes every time. It doesn’t matter if I am using the right controller by pressing buttons or not. Just before 5 minutes goes by it shuts itself off.

The left controller stays connected the entire time I am in the game though.

Have you updated to the latest firmware?

On today’s ride the right controller would disconnect then immediately reconnect every 2 minutes, got the message to say steering device disconnected (which doesn’t fit in the space btw, needs to be changed to have scrolling text).

was really annoying so just turned them off in the end.

previously, it would disconnect and then repair but look like it wasn’t connected but all the buttons worked. this is worse now as having the message pop up all the time becomes very irritating.

Yes, that is with the latest firmware.

I get the same thing so I stopped using them. I paired them up again on my ride yesterday just to see but it took only a few minutes from starting on Road to Sky course for the “steering device disconnected” message to appear then the annoying shaking from the Zwift play controllers.

I tried to persist with them but I gave up. They are nice when they work. I’m using a Mac desktop for Zwift.