Bad Zwift Support - Please help!

Hi All,

I seem to be a victim of some incredibly poor support by Zwift. I’m usually pretty chill and understanding, but this has pushed me too far, and hopefully a post here might gather some momentum / attention in getting this resolved.

Short summary:
My Left Hand Zwift Play Controllers constantly goes rogue, either constantly steering to the left, or permanently forcing on the brake. If I do a calibration on that left controller, it works fine for a short while, then randomly starts acting up again.

Common sense thinking says:
It can’t be connection because:
- I would see issues with my other devices, and even the right controller too, also a calibration wouldn’t instantly make the issue go away.
- A connection issue would likely resolve itself on another Zwift session, however the issue will remain for multiple days, up until I do a calibration run.
It can’t be firmware because:
- My right controller is on the same firmware version.
- This has been going on for over a month, over multiple firmware versions.

I created a video here… It visually shows my issue, then I talk about my rather ridiculous Zwift support journey so far.

Free riding and it jams on the brake = no big deal
Group Ride or Race = Ruined ride

Nobody should have to go this long, or to these lengths to find a solution to something that is a very obvious issue.

OMG :scream: what a nightmare going through all that communication and not getting anywhere. I will test this afternoon or tomorrow to see if my brake light goes on too……never payed attention to it. It seems to be working fine so far with me so this shouldn’t happen.

What firmware version and game version are you running?

Also are you pairing directly with the game app or through the companion app?

I don’t have that info to hand as I’m at work, but I checked last night and there were no new updates on Zwift, or firmware for the Play.

Connected directly to my PC. Tried connecting to Zwift running on my iPhone too, same result.

Try pairing using the companion app as a bridge. That’s a current workaround that seems to be working better.

Let’s just say that they need to do some work on the software for the controllers. I’m on my third set and they still have the same problems. It’s not you and you are not alone. Everything works fine before entering the game. Once in game I have no steering and constant disconnects and re-connects. The left turn “arrow” just changes the map view. Remember, they are in beta… ;-{)

1 Like

It’s doing the same if I use my iPhone to run Zwift rather than my PC. So completely different connection and device, still the same.

I have also tried pairing through the Companion App, no change.

So running the app on your PC and connecting the play via your iPhone displays exactly the same issue than if you connect directly to your PC and Iphone?

Yep, and for 100% clarity, these are how I’ve tested it:

  • PC connected via Bluetooth dongle
  • PC connected via NEW Bluetooth dongle
  • PC connected through Companion App
  • iPhone running Zwift connected directly.

What ever I do, the left hand controller will either ‘Brake’, or constantly steer to the left. If I run a calibration run, it will work for a short period on all of the above methods of connectivity, and then stop after a varying amount of time… maybe 2 hours, maybe 48 hours.

Can you calibrate the controllers? I get to the “white light” on each one and never get the vibration confirming calibration.

I guess all you can do is sit tight and wait for future updates/firmware.

Yes. Calibration works perfectly. I’ve become quite the pro at doing it actually.

Thank you for everybody’s input on here. Zwift have just emailed to resolve the issue. Case closed.

What was the resolution?

Because of the nature of the issue, they’re going to replace them.

And…I’m on my 3rd set with the same issues ;-{)

This seems to be the typical outcome when support runs into an engineering problem. They can’t solve it. They want to help. They want to give you something, but they may not have a solution. The controllers work for some but not others, and it doesn’t sound like the reason is well understood yet. I hope/assume these common problems have been reported upstream but in the mean time there’s not a lot they can do.

With game version 1.47 I had almost zero issues, just a problem with group rideons. Going forward with 1.45, 1.49 and 1.50 I have no steering but everything else works. They do disconnect and reconnect alot. I miss Repack Ridge…

It’s strange that so many people seem to be having issues with the Plays, but the issues aren’t very consistent. That is, some peoples’ Plays work just fine; my right controller loves to drop out if I steer too much; others can’t get it to connect at all, some peoples’ constantly apply brakes or steer; others have dropouts at five minute intervals, others five seconds. I’m not really sure what to make of it. :man_shrugging:
I’m not ranting, just thinking. As a rider of Zwift, these things intrigue me :slight_smile:

1 Like