Play controller firmware update problem/issue/hang

I paired both Play controllers. Companion saw them under Zwift hardware, and both showed an orange ‘Z’ logo, and the left one apparently updated, restarted, and has gone to sleep. The right controller is still sitting here with a solid yellow ‘Z’, and it’s been probably nearly 10 minutes, and it’s still sitting there.

The Companion screen shows ‘Installing 2 of 2…’, with a solid yellow line.

Oh, it also says that the left controller is connected, but it’s currently off. Looks like it’s stuck somewhere. It seems like the updating process can be interrupted and restarted, so I will try that in a few minutes as if it thinks that the left controller is connected, and it isn’t, there is a problem here somewhere. (I’ll wait for a few minutes if someone pops in with an answer/comment)


The left controller won’t pair either, but maybe that’s supposed to happen, as it seems to be stuck updating and it’s updated already.?

Are you using an Android device to do the update? Lots of reports of issues on that platform. Much more reliable on iPhone/iPad if you have one available.


iPhone. Drat… But wondering if I should blow out of Companion and try it again. Will the right controller brick, having been interrupted on its update dance?

EDIT: And of course I wanted to ride soon. It’s been well over 10 minutes. About to pull the plug and abort this mess, try again…

So I blew out, and restarted the update dance. Companion showed an update needed, and away it went, apparently. The right controller finally appears to be updated. They both connected and showed no updates needed. YEAH!!! It seems to have worked.

Case closed. (Until next time?)

And I asked, in Chat with Zwift support, repeatedly about hardware version, and was closed down without an answer.

For some reason I don’t manage to find my play controller under ZC App in hardware. So I can’t update them or see if it needed to be be updated
All Bluetooth connections are turned off except for my iPhone, but it’s not pairing

Are they charged up? Do the ‘Z’ lights come on?

Are you really positively sure that they aren’t connecting to something else?

Hi Robert!
Everything is turned off, the blue lights on the controller are flashing, but I can’t pair them on my iPhone.
Once I turn on Zwift, they do pair with the pc as they are working fine within the game.
It says Bluetooth is disabled
Both controller are fully charged.
As I turn on ZC, select Hardware and straight away this message appears, not even trying to find or durch for any connection

I have had to turn my iPhone off and back on to get it to connect to some Bluetooth and wifi setups before. It doesn’t seem to make a lot of sense to have to do that, but I’m surprised at how many times it works. I’d recommend that, and also see if you are up on all the releases/updates for the iPhone and Zwift. Fluff those pillows…

Thanks Robert, but have done this all servers times, didn’t make a difference. Zwift, ZC,IPhone all up to date. Puzzles me, why it doesn’t work

Above, you said that the iPhone is saying that Bluetooth is disabled, yet they pair to a ‘pc’? If that’s the case, there might be something wrong with your iPhone. You could try to do a restore of the iOS by connecting it to a computer and going through the restore process. But first, swipe down from the top of the right side of the iPhone screen and make sure that Bluetooth isn’t off, it should be blue. Just in case…

You could download a Bluetooth development app called ‘LightBlue’ and see if your iPhone receives any Bluetooth signals at all. It’s the only free one I’m aware of, and will show if your iPhone Bluetooth system works at all.

Robert, thank you very much for your input. Since the last apple update on my iPhone, perhaps something did go wrong, cause once someone wants to call me, the answering machine goes on, the 2nd call comes through.
Now, I downloaded ZC app on my IPad, and finally I could pair and update the Zwift Play Controller. Checkt them afterwards with the IPhone, but still the same there… nothing
Thanks for pointing out, that the problem might be my phone and not the one who is holding it :joy:
Thanks for all your input, advice and help.
Cheers Rob

Just an aside, as this happened to me a few years ago on an older iPhone: After an update, several lf the features didn’t work well. It seemed that the thing was possessed by demons!

I called Apple Support, and they asked if I had shut it down and restarted it (rebooted it). Well, no because it had restarted as part of the update, I said. They pushed me to reboot it, and it totally fixed everything. As a result, after ANY update on any Apple product, and even Windows, I reboot after any update.

I remember being on a support call with third level techs at Microsoft, and the engineer I was talking to had me install a ‘minor update’, and claimed that I didn’t need to reboot, but the update appeared to cause a problem and after nearly 15 minutes of listening to his advice on what to do and assurances that I still did not under any circumstance need to reboot, I rebooted it. Like magic, it came back up and everything was back to normal, and he was ‘shocked’. :roll_eyes:

Oh, depending on the age of the iPhone you have, I had issues with an older model that wouldn’t pair with anything, and ended up deleting the existing devices on that iPhone, rebooted, and it worked again. It didn’t make sense, and still doesn’t, but it did work.

You could open a case with Apple Support too, if it’s still under AppleCare. Let them deal with it.

Good luck!! (Yeah, it’s the iPhone) Have you tried doing a restore on it?

I’ll do that and keep my fingers crossed. Thanks a million Robert for your helping hand.
Held The Repack Rush indoor challenge this avo, as the controllers are now working properly.
3 contestants, 10 years of age. Each of them was a winner, as I had prizes for each of them.
The kids beat everyone and everything.
With 2:47 min, 2:48 min and 2:50 min. Was a close call. Can’t keep up with them at all
Cheers and thanks again

1 Like