ZWIFT PLAY latest firmware update problems

Hi, anyone else while trying to update the Zwift Play firmware got the 2 controllers stuck on a yellow led? Looks like the companion app didn’t manage to update and now they are completely frozen. I tried to push the Z buttons for like minutes but they don’t turn off. Left the batteries die and then plugged to recharge: still yellow leds and no response. Can anyone help? I also wrote to the Zwift support (email because the chat doesn’t start).

Has happened to me a as well (a few times even). It is a known problem and it certainly looks like the controllers are bricked (as this is called). Just contact Zwift support, they replaced my Zwift Play a couple of times. This has caused me to refrain from updating the firmware using my Android phone. Now borrowing my son’s iPhone for this task and that has been troublefree so far.

Hi @gianluca_belmonte, welcome to the forums!
Fernanda from Zwift here.

I’m sorry that you faced this issue with your Zwift controllers, I see you’ve already reached out to Zwift Support via email. Let’s continue that email conversation so we can help you get this figured out!

We will keep an eye on your case!

Thanks Fernanda, your colleague Francisco is actually trying to find a solution for my problem. Thanks!

Thanks Tim. I’m already updating via iPhone, so I hope this thing can be solved easily with no need to substitute the hardware. Let’s see :slight_smile: