Zwift Play firmware update 07-15-2023 FAIL

On Friday July 14the I Zwifted and used my Play controllers without issue. Saturday July 15 (2023) I opened the companion app on my phone and saw that there was a firmware update available for the Play controllers. So in the afternoon before my Zwift session I updated the firmware on the controllers. Now only one controller will work in game. I paired both controllers, but the game only seems to respond or recognize whichever controller was paired up first. I know this from attempting to troubleshoot it.

I am running Zwift on a Samsung Galazy S7 tablet with Android 13 and all software and apps are up to date.

I am convinced that Zwift needs to hire more competent Android programmers. I’ve experienced about a 50% fail rate on your frimware updates - where a new update causes some considerable gameplay troubles.

ZWIFT, PLEASE ROLL BACK THE PLAY FIRMWARE TO IT’S PREVIOUS VERSION, AS YOUR LATEST RELEASE DOES NOT WORK ON ANDROID!

How do you repeatedly release firmware without testing it and verifying that it functions properly???

What is you Firmware 1.1?

Same here, my Zwift Play controllers received (delivered) 19 June, todays update crashed and RH unit would not switch off (orange light) now totally dead. These never worked properly from the get go, crashing virtually every ride and RH unit forever dropping out. Today is 17th July, less than a month after receipt, yet the interface won’t allow me to return as the order expedition date was 15 June. I stopped using the units after the first week because of the crashes, and now they are good for the bin!

As I stated in my original post, the firmware was updated on Saturday morning to the latest and not so great version. According to the companion app, I have firmware 1.1.1

I tried to update my Play controllers through the companion app. My phone lost connection, but the left controller’s light stayed on orange and the right controller flashed blue. I could not get the controllers to connect again so that I could continue the update. I tried to switch off the left controller, but it would not switch off. I held in the start button for 1 minute and then it switched off, but now I cannot get it to start again. It does nothing when I press the start button and the light doesn’t come on. The batteries are fully charged. When I plug in the charger it also does nothing and the light still does not come on. Please assist in how to switch on the left controller again.

I have exactly the same issue. For me, the LH unit seems to be totally dead.

Does anyone know how to solve the problem?

Contact Zwift support to resolve this.

Shuji at Zwift HQ here. Not all the symptoms in this thread point to the same root causes. For one-on-one assistance, please contact my Support Colleagues to work through your issue.

@Trevor_Holdsworth_AS in your case, please try the following and let us know if this resolves it? It sounds like your controller is hanging in a state where this steps may help.

  1. Fully charge both controllers
  2. Restart Companion and reattempt the firmware update. Refer to these step by step instructions for more detail.

I am still using firmware 1.1.0 and the play controllers are working perfect. Are there any new features in the new firmware? Is zwift publishing release notes of the firmware? In my opinion you shouldn’t fix hardware if it ain’t broken.

thing is lots of people have been having issues so they have been releasing patches and fixes for that

Unfortunately patches doesnt help if you cannot get the unit to start
so that you can upload the patches.