Zwift Play controllers 'dead' after hard reset

Hi all. I bought the Zwift Play controllers a few weeks ago and apart from an occasional lack of response to some button presses in game, they have worked pretty well. Yesterday I was informed there was a firmware update available via the Companion app and attempted to install it, as I have done a couple of times previously.

Both LED’s turned solid yellow and remained like that. The firmware update failed to install.

After six hours, and multiple attempts to resolve the issue I hard reset both controllers by holding down the power buttons for 30+ seconds. The LED’s switched off but I could not switch the controllers back on. They appear to be ‘dead’. I’ve had them both on charge overnight so battery level shouldn’t be a factor.

Is anyone aware of a keypress sequence that is required following a hard reset or are my controllers bricked? Or am I missing something really obvious?

TIA guys,

Contact Zwift support.

Exactly the same thing happened to me. Both controllers totally dead after a hard reset following an unsuccessful firmware update. Waiting for Zwift support to get back to me again,

Tried that, but just keep getting the automated responses. Is there a support email address or is ‘chat’ the only option?

Interesting, and glad it’s not just me! Let’s see if theres’ a ‘fix’ that doesn’t involve having to return them!

Keep going through the automated responses and saying it doesn’t help, and eventually you’ll get to an option to contact support.

You can message them somewhere on there. I’ve got new controllers being sent out now, the bricks are going back…

Thanks @Steve_Hammatt Really appreciate that. Thought I was missing something.

1 Like

That’s good to know @Fraser_Law_KVC Thanks! Hopefully my issue will end up getting resolved the same way!

Hopefully the new ones don’t suffer the same fate as the originals…

Fingers crossed!

Has anyone who had this happen been able to get a response from Zwift support? I’ve tried “that didn’t help” option in the Support hub and nothing happens when I finally get the option to contact them.