Zwift Play firmware 1.2.0

This update is rolling out, and it appears to contain connection stability improvments according to the changelog.

So worth updating as soon as you can, probably, if you’ve been having connection issues.

I’ve never had any connection issues with mine, maybe one disconnect since I’ve had them. I updated to 1.2 and then did a ride this morning and it was a hot mess. They wouldn’t show as connected at the pairing screen even though the Z blue light was steady and the controllers were working. Going out and then back into the pairing screen resulted in a full game crash (I have never had a crash in 2.5 years of Zwifting). Restarted Zwift and they still didn’t show as fully connected at the pairing screen, including trying to fully unpair and repair but they were functional so I just rode. Things worked except at some point the right controller must have disconnected and reconnected as I lost the visual for the ride on bombs even though it was still working.

1.2.0 is a👎 for me unfortunately.

I’d probably advise anyone that if they’re not having issues, don’t update firmware – this applies to almost any device btw. Or, at least let the new firmware be out in the wild for a bit to gauge if there’s universal feedback positive vs negative.

1 Like

I agree but I don’t mind being a guinea pig.

i had this simptoms with update to 1.1.0 and game update to 1.45.

For the last 14days i’m enjoying sunny days so i’m riding outside before it gets cold again :smiley:

What’s the point of buying a product that is explicitly sold as “in Bêta” and not being willing to upgrade to the latest firmware version and provide feedback?


@shooj or whoever wants to deal with issues from this update.

Installed the updated firmware and it appears to apply a brake to you so can’t move forward.

Unpaired play controllers and then started forward progress…

I have video il link to once I finish my ride.

We have 2 pairs of Zwiftplay controllers, one for me and one for my son. I saw the Firmware update announced somewhere and got a notification on Companion app. I opened it and updated firmware on the Zwiftplay on my bike, no problem. Turned everything off and went to update Firmware on my son’s bike and when connected, Companion app doesn’t show the update notification and says firmware is up to date but it’s showing 1.1.1.

I’ve tried everything I can think of, even signing out of Companion and logging in as him but the update isn’t showing.

I know it’s a progressive rollout, but it makes no sense to me that 2 pairs of Zwiftplay in the same location aren’t getting the updates at the same time.

The rollout is rumoured to have been paused so it’s inconsequential presently.

The rollout isn’t done geographically either.

1 Like

The Zwift Play controllers keep getting disconnected after about 10 seconds with the new firmware. it is a mess

Seems to be an issue with the new firmware. I suspect a fix will be released soon.
This is part and parcel of a beta product, a few teething problems.

Mine do this every ride now and i didn’t get the new firmware before it was paused.

it must very briefly lose connection, everything still works but it seems like the UI doesn’t know the controllers are paired as all visual stuff disappears. (except for the icon on the nearby riders list)

Where was that posted please?

Saw it on Facebook somewhere. Could be a rumour.

Thanks Stuart

I received the update today, so I guess the rollout has not been stopped. Unfortunately it only partially fixed the connection problem for me.

I just got the update today, 8/27/2023 So it is not paused.

Me too.

Didn’t change any of the issues I was having either. Didn’t notice any difference.

Agreed. RH connection lost almost immediately. LH seemed to last longer. All notifications at the top of the HUD about steering and using the Z, Y buttons etc disappeared, except for the right hand side rider list which always showed me as having a steering device. RH steering almost never worked, Z button never worked, but strangely the menu button worked, and the Y button worked. More strangely, RH steering started working away from the RP, then lost again when rejoined RP. No idea whether that’s a coincidence.

mine was doing all of those things before the latest update and firmware update (and still is after both too)