Zwift Play won't stay connected

Hi all, first time post. My zwift play controllers have worked fine since i bought them in July, but now wont stay connected for more than 2 mins before they drop out. I contacted zwift 3 times over the past few weeks and have had no response from technical support.

Im running all the latest firmware and hardware updates (as of 31 Oct 2023) this started after the 1.50 zwift update (now on 1.51.0 and no change) and the controller 1.2.1 firmware.

My controllers are basically paperweights. Is anyone having the same problems as its driving me mad and zwift support are conspicuous by their absence.

Any help would be greatly appreciated.

Thanks Dave

Same problem here. I’ve given up on them.

Thanks Siobhan, glad to know its not just me, its frustrating that we are getting no support.

Dave welcome to the forum. You are not alone as there are several forum posts on the topic, just search for Zwift Play in search facility top right of your screen.

Plenty of advice from Zwifters but unfortunately not too much from Zwift themselves. Many have had replacements but there are possibly many others who have had no issues.

This might be one thing to try but if this doesn’t work for you read through this thread and others.

I am having the same issue. They connect at the beginning but then disconnect during the ride. The controllers will not stay connected for more than 15 minutes.

Well after another frustrating afternoon trying every possible and suggested method of connecting zwift play and keeping the connection, i finally give up and have removed them from my bike until zwift sorts out an update to solve the problem

Sorry you have had a terrible afternoon. There is a chance that you just have faulty Zwift Play controllers. Others have replaced them and reported that Zwift have been helpful in that department.

I’m not exactly sure whether you should go through Zwift Support or not - others may comment/advise - but it might be worth considering a replacement or refund through this link.

Thanks Ian, much appreciated.

1 Like

This fix worked for me. Thanks for posting this!