ZwiftPlay Controller Disconnects

I purchased the Zwiftplay controllers when they were released. I immediately had issues with the right the right controller disconnecting. After various attempts at solutions with Zwift support the controller was replaced. The disconnects stopped temporarily, then the problems came back. There were 3 consecutive days of updates. The first one did nothing, the second one solved the problem, the third undid what the second one corrected.
now there have been 2 consecutive days of updates, neither has fixed the problem. Now the disconnect happens as soon as i start the ride.
So what i have tried to remedy this per Zwift, i have reset the controllers, deleted the preference and knowledge files and when Zwift asked that i send them pictures of my set up and connections it got me thinking that maybe some of the wireless bluetooth items i have nearby could be interfering, so i removed the speaker and trackball so that they were further away from the controller, this did nothing.
I am convinced there is some type of program issue in Zwift that is causing this as i have been unable to find anything in the local area that could be causing the issue.
Has anyone else been having this problem? What did you do?

Join the club. I’m on set 2 with all the same issues you are having. I can pair them and watch them disconnect right in the pairing screen. When they do pair/connect properly it’s for a varying time. I thought they were ANT+, but it’s BLE that they use, I do get a Steering Device Disconnected message in the HUD but they still function for steering and power ups for some reason, I do lose the haptic (buzz) though. Since 1,45 they’ve been pretty bad.

yeah, it’s really weird that the controllers still function even though the “connect icon” is gone from the HUD. That happens to me as well. I am on my third right controller in trying to fix this but have no realized, it’s not the controller, but zwift itself. I’m don’t know what BLE is, running windows 10, with all current updates, and current firmware on controllers.

Bluetooth® Low Energy (LE)

The Bluetooth Low Energy (LE) radio is designed for very low power operation. Transmitting data over 40 channels in the 2.4GHz unlicensed ISM frequency band, the Bluetooth LE radio provides developers a tremendous amount of flexibility to build products that meet the unique connectivity requirements of their market. Bluetooth LE supports multiple communication topologies, expanding from point-to-point to broadcast and, most recently, mesh, enabling Bluetooth technology to support the creation of reliable, large-scale device networks. While initially known for its device communications capabilities, Bluetooth LE is now also widely used as a device positioning technology to address the increasing demand for high accuracy indoor location services. Bluetooth LE now includes features that enable one device to determine the presence, distance, and direction of another device.

1 Like

i looked that up on the windows control panel and found it under the bluetooth section. I saw all my bluetooth peripherals listed but no controllers. So i turned on the controllers and paired them. i then turned off the controllers, closed the section then went back in to check. They were still paired.
i will be riding shortly to test this out. I will post after the rider if it has made any difference.

1 Like

Just did the same. Can’t be worse I guess.

just tried it, no success, oh well

1 Like

I had this problem when my Zwift Play arrived, but I updated the controller firmware via the Companion app, and everything has been fine since.

i have done 3 firmware updates since purchasing

exactly the same for me, done all the updates.

Right controller drops out all the time, still steers etc, but once dropped out the ride on bomb graphic no longer appears even though if you hold Z it still gives them.

Zwift support told me to. leave them permanently attached to power with the cable - it helps a bit.

Wish they would just function properly.
Seen lots of reports of zero issues which is even more annoying.

Exactly the same experience for me. When I fist got them, they worked flawlessly, but for the last few weeks, the right controller drops out all the time with the “Steering device disconnected” banner coming up. I then get continual vibrations which I assume is every time is drops and reconnects.

Even though no graphics come on screen it does look like I can still give ride on bombs etc.

Zwift support told me it was a known issue and to stay tuned for a firmware update…

they’ve been telling me that since mid July and had 2 or 3 firmware updates since that haven’t fixed anything :frowning_face:

:rofl: I spoke too soon. Mine disconnected this morning.

just got an email back from Zwift regarding this. They state that they are aware of the mass problems and are getting ready for another firmware update that should resolve the issue.
not holding my breath on this.


I have had my controllers exactly for month and they have worked flawlessly until today, where both where connected for roughly 15s and then disconnected permanently. When just running Companion I can still see them in the Companion hardware section, but they don’t connect in game when Zwift is running.

is the above the same situation as original poster/others, or are your controllers also gone from Companion-hardware section?

mine still show on my PC under the Bluetooth section, they are also listed as zwift hardware on the companion app. The controllers still function after the disconnect, they just aren’t as instant in reaction and i don’t get any kudo power bomb wheel, though the u-turn wheel still displays

1 Like

Braking is now broken too. Right hand brake does nothing, left hand brake does nothing but also buzzes the whole time its pressed

For what it’s worth - I tried connecting my controllers via the companion app bluetooth bridge and they have worked perfectly for 2 rides. Of course I’ve probably jinxed it now!

Before that, I was connecting to my PC via a bluetooth dongle…

but then you have to connect all bluetooth devices via companion correct?

I can’t try just my plays via companion and still kickr bike and HR via PC bluetooth

Not sure - I use Direct connect for my Kickr and Ant+ for HRM