Zwift Play - Android connection Issues

I received mine yesterday. Charged them and attempted to go for a ride today.

Originally I tried to connect through the Companion app on my Samsung S20 to my Apple tv onto a tv. Either the Play would connect and my hrm, speed sensor, and cadence sensor would not or the other way around.

After about 30 minutes I tried with my Samsung S20 and the Zwift app. Hrm, speed sensor and cadence would connect but Play would not even show up as an option.

Will try again tomorrow and if they don’t work I’ll either wait for update or just send them back.

Have enjoyed Zwift so far so they aren’t necessary.

Chris, thanks for posting this. I’m having connection issues too, but intermittently. Day 1, no connection. tried Bluetooth and phone. Day 2, firmware updates applied and connected easily. Day 3 connected. Day 4 and 5, no connection. intermittently one or two of the controllers show up in the steering box, but they don’t connect. Well, one time the right controller connected. Then yesterday I just gave up. Turned them off. The right controller then restarted itself. Shut it down and it came on again on its own. Shut it down again and it stayed off. I liked using it but wish it connected more reliably.

I haven’t had the latest android update yet but when i do i’ll see if that makes any difference and keep this post updated

I’m running Samsung S10 version 12 and having similar issues with Apple TV.
I can pair the remotes to the Companion App on my phone, but then when launching Zwift on Apple TV and trying to pair Steering to Companion App, it doesn’t “find” the devices.
I have all other Bluetooth Connections turn off, too.
I also tried pairing the remotes to my IPad Pro but I can’t even get the Companion Spp to pair with them at all, so of course Zwift on Apple TV won’t do anything.

I got the latest game update on one of my devices today.

good news is i got them to pair and they worked and i rode for an hour and a half with no crashes.

It took some time to initially pair them but i found these steps to work:
open the steering pair tile
deselect both controllers.
select one
wait for the haptic buzz to say that is connected
then tick the second one and wait for that to buzz
then click okay

ticking both before one has paired and buzzed meant it wouldn’t pair, selecting okay before the second one had buzzed also didn’t work.

after that i was able to use them to navigated the home screen menus, steering in game worked, all the buttons in game worked.

So looks as though the latest updated has fixed my issues (assuming you pair them correctly)


Any thoughts on getting these working with Apple TV and Samsung S10 for Companion App! Controllers still won’t connect to the Companion App for me.

Haven’t used either i’m afraid.

Are you able to run the zwift game on the S10 just to see if they’ll connect to that? to rule out the controllers being the issue?

if you follow my steps above i have got them to work on two different android devices that way.

They work if I just run everything on my iPad or everything on my phone via Wi-Fi. But they won’t pair if I run from Apple TV and connect controllers via Bluetooth. All other Bluetooth connections are off.

Zwift 1.43 update solved my issues. Worked very well during 2 hours workout.