Zwift Play connection and crashes - PC, Android [June 2023]

Hi, my set are being replaced. The controllers dropped connection over forty times in two rides. Tried Zwift support recommendations but to no avail. I have to say the customer support has been excellent but the product is frustrating. I should be receiving my replacement this Saturday and I’ll report any improvements or otherwise.

I had the crashing issue where after a short while using them Zwift would crash.

I did the 1.1 firmware update this morning and now it’s even worse. Can’t even start a ride. Zwift crashes after pairing them. I think it was when I paired my Fenix 6 for HR but didn’t have time to investigate further as needed to get on with my ride. I will do some more testing.

Samsung Galaxy Tab S7.
Android 13.
Latest version of Zwift.

updated to 1.1 last night and did and hour ride with no issues on win 10 machine

Has anybody here got these Play controllers working RELIABLY on Android via Bluetooth ? I have upgraded them to v1.1.0 firmware. I eventually got them both paired at the same time and completed Repack Rush. The left-controller then dropped out, and I used the in-game Bluetooth menu to reconnect it. 30 seconds later the game crashed.

So far as I can see these do not work on Android. Period. Somebody tell me I’m wrong !

There’s several reports of issues. I’ve not yet tested them on Android but leave that with me.

I made a seperate post here:

i have tried on different android devices with no luck

1 Like

I have a high end PC that has run Zwift without issues but connecting the new Zwift Play and trying to use these causes Zwift to crash to the desktop. I have the latest firmware update.

ANT+ or Bluetooth to connect?

1 Like

Bluetooth for play other equipment is Ant

There are numerous reports of the same. I’ve no doubt the team at Zwift are working around the clock to identify the cause.

Same issue here: all devices connected by ant+, Zwift play via bluetooth. Five crashed over the last hour. Never had zwift crashes before.

When working, connection with zwift play lost many times. Now connected zwift play via companion app on smarthpone (bluetooth), seems a lot more stable.

Exact same issue here: multiple crashes of Zwift (about 5 in 1 hour), Zwift play not working at times (connection lost). Never had crashes before.

Using following hardware:

  • Windows 10 desktop running Zwift
  • Zwift play with last update running, connected via Bluetooth
  • Wahoo Kickr connected via ant+
  • HR monitor connected via ant+

Also figured that the crashed had to be caused by Zwift play being connected to the PC via bluetooth. Therefore connected Zwift play via companion app (bluetooth) on Android smartphone. Other devices still connected via ant+. Was running fine without any issues, only at times a bit slow in response to the buttons on Zwift play.

Another couple of runs tonight

  • Bit fiddly to connect via companion app but got it there eventually
  • No issues in game - controllers worked as they should, no crashes or any issues - Joined an event (standard ride) with no issues - lots of steering, ride on bombs, emotes, etc all fine.
  • Tried Repack Rush and it seemed to work properly with steering working about the same as in the event (previously it seemed less responsive).

So in short, it now seems fine for me… more testing to confirm.

W10, 1660 Super GPU, 16Gb memory, i5. ANT+ connections for everything except the play controllers connected via CA.

1 Like

Using the companion app to pair all devices worked a treat

I had a pretty bad experience with mine.

I was immediately given a firmware update to 1.1.0 so that’s the only version I’ve used. The update went very smoothly. Better than any firmware update process I’ve done with Tacx or Wahoo.

Trying to pair with built in Bluetooth on Windows 10 they always got stuck in a loop connecting and disconnecting every second and then eventually Zwift would crash before I could even get past the pairing screen. It seems to be some issue with the handshake. I remember the Sterzo had this problem too the first few days after it launched.

Then I switched to using the Companion app as a bridge on a Pixel 7 Pro and it wouldn’t detect any of my devices. I used to use the Companion app as a bridge all the time but it’s been a few years and something seems to be broken with it now. But anyway, after restarting Zwift and the Companion app about five times each it finally worked.

Everything was great for about 20 mins. Then I teleported to a robopacer and it caused all my Bluetooth devices to stop working. I went into the pairing screen and it said everything was still connected but no data was coming through in game. I unpaired and repaired everything and all was good again.

Everything was great for another 50 mins or so just teleporting between different robopacers. Both controllers working fine, no drop outs or anything.

But again all Bluetooth devices dropped immediately after a teleport. It must be a separate bug with the Companion app but probably not related to the Play controllers.

I unpaired and repaired my Kickr again but the Play controllers wouldn’t appear. Then out of nowhere I got a popup for the original Sterzo steering tutorial. Then randomly two instances of VLC opened. Then a second pairing screen popped up inside Zwift which I couldn’t close so now I was stuck in the menu. I pressed the X on the Windows GUI to close Zwift and the save ride screen came up. I tried to save the ride but that didn’t work either. I had to kill Zwift with the task manager. A bizarre cascade of bugs.

Overall they work fine for me when they’re connected but I must have spent 20 mins battling to get them to (re)connect which is not worth the effort.

Adding another voice:

Windows 10
Connecting via Bluetooth
1.1.0 firmware

Worked fine on original firmware, now connecting the controllers causes zwift to crash, either on startup pairing screen or if I manage to get into the ride it’s just a matter of time.

UPDATE
After multiple restarts
Managed 40 minutes with them connected and working then crashed

Started up and immediate crash as soon as soon bluetooth tries to connect.

Rode for 1hr20 without connecting no problems. Stopped and went to pairing screen and immediately crashed.

Updated bluetooth drivers and restarted. Loaded and the devices connected, I disconnected them and reconnected and it crashed.

I have bluetooth headphones so tried with and without, no difference still crashes.

Ran as administrator and got them to connect. Disconnected and reconnected. It says ‘connecting’ and then crashes.

I notice that the Bluetooth connection is really poor, and up and down despite only being about 2m away from my pc.

Seems it loses the connection, tries to reconnect and the second reconnect causes a crash.

SECOND UPDATE:

managed to get them to work (at the moment):

do one at a time

  1. Conenct bike completely (all aspects)
  2. Connect HR, wait for HR to show
  3. Connect right controller
  4. Connect left controller
  5. Pray

Seems like the multiple BT connections are overwhelming the application

1 Like

You are not wrong. Im on android 13,samsung s21. Spend more time getting to connect than actually riding when i do manage to connect because the app just crashes randomly

After updating the firmware zwift also crashed at my windows 10 PC. After I switch to connection through the companion app I have been able to use the Play for 2 longer rides without any problems.

Same for me today, once on the summit seeker up alpe du zwift on the way to a new PR and now again after climbing and descending epic kom…
windows 11 and latest versions and zwift play (also update applied)

So acknowledging that likelihood is people post more when something isn’t working than when it is, can I ask if anyone has the Zwift Play working trouble-free (and/or more specifically on a W10 machine)?