Zwift Play connection and crashes - PC, Android [June 2023]

I will add my experience. Zwift play is much more stable when paired through companion than on my Windows 11 PC. ZC occasionally has trouble establishing the initial pairing but is stable once it does. PC continuously drops, and either the Play has to be reconnected via the pairing screen or switched on and off to reestablish connection. The PC is about a meter from the Play controllers whereas the ZC device sits between the controllers. Also, I noticed no discernible difference after updating the Play firmware. I’d like to be able to pair to PC to preserve device battery life.

Windows 11 HP gaming PC
iPhone 14 w/ ZC
Kickr v5 w/ direct connect

Lots of variables, but is the Play connection a (very short) range issue?

I did but then I’ve killed my PC so can’t offer l long term consistency.

I’ve only used them for about an hour and half and had zero issues on a windows 10 machine, have updated the firmware but not tested them yet

1 Like

I have Win11 Desktop, AMD Ryzen 5600x proc, GTX1060, Neo 2T on BT, cadence with separate sensor on BT, HRM on ANT+ and Zwift Play 1.10 on BT. All drivers up to date, Win fully updated. Done a long ride yesterday (Alpe du Zwift with robo pacer E about 2 hours) and a OG race today (about 40 mins). No issues for me at all - no disconnects, no crashes, using steering a lot.

1 Like

My worked flawlessly out of the box on 2 different windows 10 PCs but android on the other hand is a definite no!

Using ATV, second time I’ve used the controllers and neither left or right steering paddles do anything. Everything else works. Tried restarting Zwift and tried recycling the controllers but still no steering. My son got his Play controllers the same day as me and he’s on a PC and he said that his steering stopped working too. We both got the firmware update 1.1 before we even starting using our controllers when we first connected them up.

I have this exact same problem. Left play controller is stable while the right controller periodically loses connection.

When Zwift launches and connects to the controllers, while the right controller successfully pairs, the buttons never initially work. To get the right controller working, I need to disconnect and reconnect the bluetooth connection at the pairing screen. After doing this, the right controller buttons work anywhere from 60 to 90 minutes and then the connection eventually drops again.

I dont have this issue with the left controller, just the right.

Zwift Play firmware: 1.1.0
OS: Windows 11
Connection: Bluetooth directly to PC (Not paired through Companion app)
Trainer: Wahoo Kickr Core with Kickr Climb
GFX: Nvidia GeForce RTX 2070 Super

1 Like

Very frustrating experience with controller connection instability. I’ll give Zwift some time to address the matter before I process a return of these “paperweights”…

I’ll add myself onto this list. I had the exact same behaviour as the original poster on this thread.

I use an Android phone for Zwift, my own phone for the companion app and have been happy for about 3.5 years with very little issues.

I even changed the phone I use for the Zwift app with the same issue. Using a Samsung S23 Ultra and has the same issue.

Its not Android. I develop Android apps and the BLE handling is probably as good as anything else out there. If it was the BT then everything else would be dropping out. Its the app and or FW for sure.

1 Like

charged up my tablet last night to give this a test, its a huawei matepad 10.4 running harmony os 2.0.0 and the latest version of zwift and first it took an age to connect to the tablet then promptly crashed zwift, tried it again and same result, unpaired the hr strap they then conencted and reconencted the hr strap and gave repack rush 2 minutes and it was stable but not sure i would have trusted the conenction

booted up the windows 10 machine used purely for zwift with bluetooth being provided by a
Gigabyte WB1733D-I 1733Mbps PCI Express WiFi adapter that does bluetooth 5 and took slightly longer to connect with 1.1.0 firmware compared to 1.0.0 but did 30 odd minutes with 2 pace partners and it was solid as a rock

I think we’ve well and truly established that the Play controllers and Android version of Zwift is broken.

Fingers crossed a fix is on its way.

Hello everyone,

Thank you so much for raising these issues.

  • For the Android crash, we have a fix coming soon in the next version of Zwift. Your Play controllers won’t need to do anything.
  • For the PC freeze/crash, the current investigation also indicates that this is a game issue and not directly a controller issue. We’re working on a fix to be released as soon as possible.

What about ATV. since updating to 1 1 and connecting through companion app, 15 mins in, disconnects everything from zwift and can’t reconnect properly. Have to log out, log back in and connect trainer and HR through Bluetooth and can’t use Zwift play. Worked perfectly when I first got them.

Same for me today. Firmware 1.1 windows 10 machine.

Right hand play dropped out yet again. Turned it off and on started working again. Then 7 seconds before the start of my ladder league race Zwift hung and crashed. Never had it before. I’m blaming the Zwift play.

Will only use in robopacer etc from now on not worth risking for something I feel is important. Let the team down and lost the race due to 5v4

Rant over.

It’s been confirmed as an issue and being looked at

Took part in a race where steering was turned off, part way through event I had a Bluetooth issue with a warning telling me that trying to pair a different device during a race is not allowed. Never seen this before and I was not trying to swap any device, anybody else notice this with play and steering turned off?

Just to clarify the PC freeze/crash is a game related issue and not Zwift play?

I’m on firmware 1.1 and right hand controller drops out all the time and has to be cycled through power to reconnect. Tonight I then had the game freeze 7 seconds before the start of my race.

Are they separate issues or related?

I will add my 2 cents worth of info.

I have now used my controllers 4 times.
The first time was just to get use to them and find out how they work. Was not a good experience if I say so myself. I could use the left controller to move about the screen to make selections but I could not select anything with the right controller.
Gave up that day and waited till the next day.
That is when I seen the update notice on the companion app. did the update and then fired up zwift and went for a ride.
Everything worked great. Connected right up showed the battery levels and while on a ride i was able to use all the functions of the controllers.
The 3rd ride was just like the second ride during the ride everting about the controllers was awesome, but then came time to end ride, it went down hill from there. For some reason I could no longer select anything with the right controller. I could scroll around to the different “buttons” but when I pressed the"A" nothing would happen except that the button that I had choosen would just flash and flicker like I was passing the mouse over it quickly. I had to use the mouse to end the ride and close zwift.
Then there was the ride today. I ended up not being able to use he controllers at all. While on the pairing screen The right controller would pair right away, going from a flashing “Z” on the controller to a steady “Z”. While the left controller would just stay flashing “Z”
BTW they both were blue “Z”'s
I tried to unselect both controllers and turned them both off. Then I tried to just turn on the left controller. It came up in the steering column on zwift but the controller itself would just stay as a flashing blue"Z"
I tried restarting the zwift game still same results.
I did notice that someone stated that maybe that the Bluetooth is very short range so tomorrow maybe I will try to move my laptop a little closer and see if that maybe helps.