Zwift Crashing/Freezing Mid ride

Unfortunately it crashed about 10 mins after my last post, same error on event viewer.
Not sure why it lasted so long at first but it’s crashing within 10 mins every time now.
Completely uninstalled drivers before reinstalling new drivers without joy. Tried a few more different drivers including the earliest ones I could find from 2017, same result.
I guess that means the GPU is goosed then?

Despite lots of people recommending it, I’ve yet to see any evidence whatsoever that the Nvidia driver version in use makes any difference to Zwift - either to performance or stability. This is assuming the install went through properly of course, there are always a few folks who get joy from a reinstall/update. The only benefits of newer drivers (virtually any from about the last year) are a couple of useful features found in the Nvidia Control Panel.

Without going through everything about your setup (for example is it still crashing with all USB devices unplugged?) then unfortunately yes, I’d say it seems likely that the graphics card is kaput. :confused: Can you borrow one from family or a friend to test?

1 Like

I’ll keep trial and erroring things so see if anything works. Only thing plugged into USB is a mini wireless keyboard dongle and the Ant+ extension cable. I’ll trial unplugging these.
Could the TV itself cause a crash? … it’s just a budget supermarket 32” full hd lcd tv connected to the pc with a 2.0 HDMI cable. One thing I do have to do is bring the tv out of standby first before I power on the pc or no picture shows until a pc reboot.
I should be able to get hold of another GPU from somewhere to test.
Thanks for the help.

TV shouldn’t cause a crash, no. The standby issue will be something to do with the HDMI handshake between the card and TV - some combinations seem to struggle more than others for some reason. Could be another symptom of the card going bad though, I guess. Best thing to try is a different card as a straight swap (the driver and Zwift will sort themselves out), and see if anything changes.

1 Like

I agree with this approach, also in the mean time it might be worth as already recommended disconnecting every peripheral you can get away with usb`s/ Ant sticks etc and try and run it in watch mode, power of elimination however does look to be a GPU issue here. Does your Mobo have onboard GPU? some do allowing you to run basic programme(maybe zwift) bypassing the GPU to see if it runs?

1 Like

I got hold of another GPU and installed it yesterday, set it on just watch last night and it ran for 2 hours flawlessly before I turned it off.
Just done a 90 min activity tonight and again it ran without a hitch, no crash’s or errors …absolutely chuffed!
So as you guys said… dodgy GPU.
Thanks for all the help, very much appreciated. :fist_right::fist_left:


Now it crashes again despite Ver.1.19.2 :persevere:
Tried 2x Nekyo Badge hunt… after few min. Notebook crashes… “Kernel Power”
That, although I have even reduced the clock rate (“Silent”) in my ROG Zephyrus G15, because I know overclocking does not work good with zwift.

Knows quite well with PCs, but I’ve never had such problems with a program.
Really s*** :frowning:

Are still crash free @Paul_Attard? I’ve had a month of problems since last driver update & considering downgrading

Kind Regards

Yes still crash free - I did have a moment a month ago when the crashing started again - but soon found windows had updated the driver. A quick rollback and all is good, performance is fine running in best gfx setting - don’t get me started about BT dropouts though!

1 Like

Just installed Zwift, and I am experiencing the freeze phenome multiple times at around 15-20 minutes into the ride. Tried to re-install Zwift, latest version; no result. The log says:

[15:25:14] NETCLIENT:[INFO] UDP metrics {StC Rx: 671, Rx error: 0, CtS Tx: 100, Tx error: 0}

[15:25:15] NETCLIENT:[WARN] UDP connection timeout (1 so far), reconnection attempt 1

[15:25:15] NETCLIENT:[INFO] Connecting to UDP server…

Systems Specs:
Windows Intel(R) Core™ i7-1065G7
Intel(R) Iris(R) Plus Graphics

Any solution suggested?

The Core i7-1065G7 is a 10th gen chip, so the thread named “Intel integrated graphics gen 10 and 11” probably applies.

I can’t include the link to that thread since these forums don’t allow links.

Yes I have in the week before Christmas. Bought a new Lenovo laptop in october and had crashes all the time. Intel I5, 10 gen, UHD graphics. Installed the drivers released Dec 3rd 2021 and did approx 8 1-hour sessions since and a 3 hour run of ‘Just watch’. No crashes till this point. So slightly positive.
Currently I use Zwift as follows: ‘run as administrator’, screen: ‘windowed’, resolution: medium 720; laptop battery saver: max battery saver.
Did not check high grahpics yet.

Note: when trying to update, laptop told me I had the latest drivers ( I installed a tool from Intel: Intel driver and support assistant installer (DSA); ( com/content/www/us/en/support/detect.html). This detects the new drivers and have you install them.
2 note: the install warned me that this would override the ‘standard’ Lenovo drivers (apparently I have those); which i did; since then no issues with Zwift crashing yet.

Hope this helps for other people in this thread as well.

Ride on!

1 Like

My previous gaming laptop that I used for Zwift died after I spilled a cup of coffee on it. That one had a separate Nvidia graphics card and did not have any issues freezing during zwift rides. I switched to using my wife’s relatively new laptop that has a 10th generation Intel i5 with UHD integrated graphics. With that laptop I have been constantly plagued with group rides freezing (usually 20-30 minutes into the ride). Even just watching will freeze. After reading through this topic and I saw that Paul_Attard has successfully resolved the freezing/crashing problem by installing an older Intel UHD driver (Mar 2020 - I decided to try this (or else I was giving up on Zwift). My sample size of a single one-hour ride passed without any freezing after installing that driver. Clearly one ride is not enough, but I thought I’d post if anyone else here is as desperate as I was for a solution to the freezing problem. Here are details of what I did:

  1. Since I cannot post a link for the driver, go to the main Intel site and do a search for The 3rd link in the search results is the one to click “Intel® Graphics – Windows* DCH Drivers”.
  2. On that page there will be a “Version” pull down. Choose the last entry:
  3. Click on the button that has “Download” which will download the driver zip file (presumably to your Downloads directory).
  4. make a directory and extract the zip file there.
  5. shut down all programs you are running.
  6. open an Administrator command prompt and cd to the directory you created that contains the contents of the zip file.
  7. type igxpin in the window and then follow the prompts. It will likely complain that you have a newer driver currently installed but you can ignore that.
  8. Reboot … and pray :=)

Note: the first time I did not use an Admin command window and although it seemed to install the older driver, I found the latest driver was still installed after a reboot. Then I tried an Admin command window and it worked.

Many thanks to Paul_Attard and good luck to all you suffering Intel UHD graphics Zwift users!

1 Like

both my laptops freeze up,zwift not really sure, tried all there sugestion, even running directly to router,I did notice Intel service has a new upgrade for HUD ,was alittle scared to download.Never had any problems until Zwift update around Nov.18 or so .Do any one have idea how to download older version of Zwift???

You can’t obtain an older version. Follow the steps above.

Intel(R) Core™ i5-1035G4 CPU @ 1.10GHz 1.50 GHz

Been riding with driver version and the freezing issue has not been present. Thanks to everyone that contributed to this post.

1 Like

Good news, how long has it been? @Peter_Gross do you mind if I share your post elsewhere, given it’s got a good step by step guide? Particular thanks to @Paul_Attard for doing the testing and finding a driver version that worked. Assuming it’s still fine for you too?

Working fine still for me - must be 6 months now. Really glad too as I like my Zwift but didn’t fancy ditching a 1 yr old premium laptop (albeit without dedicated gfx but it is an XPS so very compact). Thanks @Peter_Gross for those download instructions. Had an issue recently where Windows auto updated my gfx driver and I couldn’t find the old one again, only way I could resolve the issue was to use a Windows restore point. Have been put off upgrading to Win11 because I might have driver issues but if I can readily access the driver I might be more inclined to upgrade.


Stick the package installer on a USB stick so you can get to it if needed. :+1:

@Peter_Gross Is there a reason you needed to use a command prompt rather than just right-clicking the exe and running it as Admin?