Problems pair bkool Go / Pro2 Zwift ant+ FE-C app Bkool indoor

hello I have the same trouble I have been using my Bkool Pro for month suddenly it cannot be controllable anymore …
It’s recognized by book through ANT+ and bluetooth
but zwift recognize only through bluetooth and not controllable…

my firmware is up to date from the information on toolkit.

Hi Guillaume,

Have you tried updating the Bkool so that it broadcasts via Ant+ FE-C? I don’t think the current Toolkit app lets you do this so you have to install the old software, I’ve put a translated guide here that might help:

Hello thank you, the link to download for mac doesn’t work
here is the page that opens
And I can’t download the file attached

This XML file does not appear to have any style information associated with it. The document tree is shown below.

AccessDenied

Access Denied

221092901E1ACB79

e6EhVwosN3Khs71gK4WUL/jWSjqXCm/G84dQDVw11KRKAYrODn0oaJXpX8KE9NwkAkkrjehmEDY=

I have been downloading the bkool program ( from bkool website) check the DAT file
the reference mentioned is 5.14 in it.

I launched Bkool and switch to ANT
There is choice between Bluetooth and ANT but no mention of Ant+ FE-C
I selected ANT+ trainer is paired with bkool application successfully

closed Bkool
Launch Zwift
still didn’t find the trainer for controllable

try to do with a notebook for windows and not with MAC. OK ?

it tried it but the link doesn’t work
it says the same acces denied

For some reason those links don’t work any more. I’ve updated the instructions with new links here:

Thank you very much it worked You saved my lockdown and the one from my wife who was worried about me not riding my bike…

1 Like

My pleasure, glad to help

Hi Sandy, hopefully you can be of some help. I’ve decided to dig my Bkool Pro 1 out and get on Zwift during the lock-down, but with no resistance this is far from ideal. I’ve downloaded Bkool Toolkits to update the trainer but keep getting “No update needed” with the firmware showing 3.1, I’m sure I’ve seen 3.25 elsewhere? I’ve uninstalled Bkool and reinstalled via your Mac link. When I open it I get a software update page and have no choice but to accept the update which then goes to the bike cockpit image page and doesn’t go any further, I waited 45 mins with no change.

If you could be of any assistance I would be very grateful.

Hi Stephen, no problem.

The Toolkit app doesn’t seem to update the firmware on the pro to 3.25 any more so that’s no help. What you need to do is update it using an old version (v3.53) of the Bkool Simulator. If it is asking you to update it then you probably need to look at step 4 below - basically you have to trick the software into thinking it is the latest version so that it doesn’t update. Try following these steps and let me know if you get stuck…

  1. Uninstall the Bkool simulator software
  2. Download the old version from here:
  1. Install the software, but don’t run it yet!
  2. Find and open a file called version.dat
  • In windows it is here C:\Program Files (x86)\Bkool Indoor\BkoolIndoor_Data\StreamingAssets
  • On a mac it is here: Find the Bkool application in “Applications”, right-click to bring up the menu and select “Show package contents”, Navigate to: Contents > Resources > Data > StreamingAssets > version.dat
  1. Open the file in a text editor and edit it so that the number inside it is “5.14” (i.e. the latest version) instead of “3.53” (On the Mac I had to make a copy of the file, edit that, then delete the original and replace it with my new version - there may be a better way but I’m not used to working on Macs)
  2. Open the Bkool simulator and hopefully it won’t prompt you to update it since we’ve tricked it in to thinking it is the latest version
  3. Go to the Pair Devices section and find the Bkool trainer - hopefully you should see the option to enable Ant+ FE-C mode, click this
  4. You might get a message to say that the update failed but this wasn’t actually true in my case - try loading up Zwift and hopefully it should appear as a controllable device
  5. Ride!
3 Likes

hello friend, I did this following the instructions for a windows notebook and not for mac.
Installing the old version of bkool I managed to turn my bkool pro1 into ant + FEC that needs to be discovered in zwift.

Many thanks for your help, I am now properly connected, thanks to your step-by-step instructions.

At first I don’t get the FE-C pairing option but after turning off the bluetooth on my Mac it came up straight away.

Thanks

Excellent, glad you’re up and riding!

Hi all, I’m having a slightly different problem, but still trouble with my controllable function on Zwift. I have a bkool smart pro and trying to run Zwift off a Samsung S6 tablet. Its picking up the trainer and cadence fine on Bluetooth but not the controllable function. And when I turn off Bluetooth the Ant+ isnt picking up anything. I tried the firmware update for bkool but I’m already on 3.1 and it says no update available. On the bkool simulator the Bluetooth and Ant+ picks up very thing fine !! But I’d like to ride with friends on Zwift.

Anyone having/had similar problems? Seems like a Zwift issue rather than Bkool but not sure.

Thanks !!
#needtostaysaneinlockdown :slight_smile:

Hi Fran, as far as I know the Bkool will only work with Zwift as a controllable device on Windows or Mac devices using Ant+, so even though you have an Android device with Ant+ it wont work.

I’m not sure if it is a Zwift or Bkool issue, perhaps even a bit of both, but I would try and use a Mac or PC if you can. If you do then you might still need to follow the steps posted above to enable Ant+ FE-C but it is possible to get it all working eventually!

Hey sandy,

Thanks a lot for ur response. I have managed to get it working on a Windows laptop with the ant+ dongle yah! Only problem is that it’s my husbands laptop and I was hoping to be able to use my own (new) device to keep it simple, shame :frowning: but least it works on something. I feel like bkool has the most connection problems out of a lot of the turbos.

Thanks Zwift guru ! :slight_smile:

1 Like

Hi Sandy. Thank you for the workaround. Appreciate your effort. I’ve tried several solutions listed below (followed by the outcomes respectively) but it seems I’m still on the bad luck side. Mine is Bkool Smart Pro 2.

  1. Bkool Toolkits (iOS): Pro 2 firmware updated to 3.25. In Zwift the Pro 2 detected as power but controllable not detected.
  2. Bkool Indoor v5.14 (Win10): Devices (Pro 2, powermeter, cadence, speed, hr) connected right away. But cant find the Ant+ FE-C option.
  3. Bkool Indoor v3.53 (Win10) - your workaround: Few devices connected (see attachment). Pro 2 is not detected at all. Hence Ant+ FE-C cant be seen as well.

I’ve been toggling between bluetooth and ant+ for each solutions. Also forced restart the trainer for each solutions. No luck.

Any clue? :frowning:

1 Like

Hi Fateh, the signal strength on the other devices looks a little weak, if you move the trainer nearer the PC does it pick it up?

Oh, and I think it needs to be connected via Ant+ in the Bkool SIM to update it to FE-C

en el paso nº5 para windows cuando dices editar el archivo, dices que cambie el nombre y ponga “version5.14.dat” ¿es correcto?
luego al ejecutarlo se queda cargando y no inicia el simulador.
la verdad no manejo mucho el tema informático.

me puedes explicar como editaste en archivo "version.dat " yo tengo windows, pero al poner "version5.14.dat " luego ejecute el programa pero no me aranca, se queda cargando. y no puedo emparejar dispositivos.

un saludo y gracias de antemano