BKOOL smart pro trainer 2

I updated the firmware and now it works!

hey! how did ypu do it, i am not very techy in this sense.
I have been using the bkloo smart pro 2 without the controllable function.
All the ANT does is onnect my HR but the controllable functions wont work.

How did you update the firmware?

Hi! It’s actually quite easy. You download the Bkool Toolkit App on you phone, unplug the trainer, plug it back, open the Bkool Toolkit App, it will detect your trainer. Now you just have to tap Update firmware. It has to be the 3.25 or later version.

Has anyone had success using the smart pro 2 as a controlled trainer on Zwift with BLE connection (Bluetooth) with Apple iOS (IpAd or Apple TV)?

Cannot find the way. It works with ROUVY (for example) but not possible to connect it as a controllable device with IpAd over Bluetooth…

Hi Iker, the Bkool isn’t contollable on Zwift with bluetooth unfortunately. You need a Mac or PC with Ant+ - The Bkool trainer also needs to have Ant+ FE-C mode enabled, which you can do by following the instructions here:

Hi Christina, do you have it working yet? If not you need to follow the instructions in the link below to enable the Bkool to be controlled by Zwift:

Thanks @Sandy_Thomson

Would CABLE device from North Pole engineering be a valid workaround for this?

It converts the Ant+ signal into BLE … so maybe potentialy could serve as a bridge for Ant+ FE-C protocol of the controllable devide…

:thinking:

I’ve not tried it but I’ve got a feeling I’ve seen a post somewhere from a person who did try it - I don’t think it worked though.

1 Like

Hi @Sandy_Thomson,

Some progress on my side on this. Bought the CABLE from North pole engineering, configured the bridge to act as Ant+ FE-C from BKOOL Smart Pro 2 to FTMS (BLE) service in CABLE…

Everything seems bridged ok between ANT+ and BLE. But cannot get resistance control work properly. It does control resistance in ERG mode (in workouts), well. perfect.
But does not control it properly when simulating the gradient.

Yes, yes, … I tried trainer difficulty slider, and makes no difference. Resistance control in normal simulation is quite random, and does not follow the gradient changes…goes, up and down, and hard and soft … rather randomly I would say.

Anyone experiencing same problem?
Any suggestion?

I got in touch with North Pole Engineering to see if they have any idea.

Thanks.

Latest update on this issue.

With the recent software and firmware update from North Pole Engineering … it now works perfectly. Resistance control matches the track gradient/incline perfect.

Great!

Great news @Iker_Arri!

So does this mean you have a Bkool Pro 2 being controlled by Zwift on an iPad/Apple TV via the North Pole CABLE?

Yes. @Sandy_Thomson
Las test update from North apple Engineering works perfect.

Trainer: Bkool Smart Pro 2
Zwift iOS on iPad Air 2
CABLE device from North Pole engineering, to connect everything via BLE (Bluetooth).

Ant+ FE-C controllable trainer protocol bridged by the CABLE device.

Everything running smooth. Resistance controlled perfectly both in ERG mode (workouts) and SIM (simulation) mode, changing with gradient of the road in free riding, races, etc.

:raised_hands:

1 Like

I’m trying to do the same with the Bkool Pro 1,

I have an iPad Pro and the CABLE Bridge But still no ‘controllable’ feed visible.

Any tips for the CABLE settings?

Hi @Tommy_Phillips9007

Guess it should also work with Bkool Pro 1.
I attach 3 photos with my config in CABLE …

Check the Firmware version.
ANT+ inputs, select PWR (Power) and most importabntly FE-C (Inddor Trainer)

As ANT+ --> BLE asigments… only FMTS (Fitness Machine)

This should allow you to choose CABLE as controllable device in ZWIFT iOS pairing menu…

Hope it helps,
Regards,

Iker A

Thanks very much for the settings, much appreciated!

I have managed to get a connection to zwift but there is no ‘bike power’ reading like you have. With f-ec connected it’s reading watts in the CABLE app but when I go to Zwift there is zero watts when cranks are turning.

I am getting closer but something still isn’t quite right?

Hi @Tommy_Phillips9007

Ummm. Getting closer. But yet not there.

I would try disconnecting the Bike Speed/Cadence signal in Ant+. I think you are already reading that one via Bluetooth direct. And maybe is messing a bit with FTMS …

Another check would be to upgrade the firmware in the BKOOL trainer. I remember I had to do that a few months back to increase compatibility with ZWIFT. Use the BKOOL TOOLKIT APP from AppStore for this …

Good luck!

Hi @Iker_Arri , this is the best-est information I got today. I have Bkool Smart Go and try to pair it with my apple tv.
I have ordered the North Pole Engineering CABLE and wait for it to arrive in Indonesia around mid July.

I see you pair it on your iPad, is it possible to use it on appleTV?

@Budi_Arifianto_Wibis

What is possible for iPad, should be possible for AppleTV. They are both using ZWIFT for iOS.

What I am not that sure is about the BKOOL Smart Go or BKOOL Smart Pro 1… I have only used the BKOOL Smart Pro 2 trainer… I do not know if older trainers are compatible or not.

Thanks @Iker_Arri.
The CABLE will arrive in Indonesia within days…
I’m going to post again after I tried.

Hi @Iker_Arri and all trying to connect B-Kool trainer to Zwift using Apple TV, or iPhone or iPad,

Just want to share that I managed to do it with following setup:

  • B-Kool Smart Go
  • Apple TV 4K
  • North Pole Eng. CABLE

The CABLE configuration is as per mentioned by @Iker_Arri above.

As you can see I also attached my Garmin HR Monitor Strap, through ANT+ input in CABLE.

Thanks all! Happy Zwifting!!

3 Likes