Bkool Smart Pro 2 not detected


My bkool trainer (smart pro 2) is not detected on Zwift.
On bkool simulator, it works well, and it says my bkool trainer is already using ANT+ FEC.

So, why i cannot pair my trainer on Zwift? Need some help please.

Thank you,

Here some screenshots :

On Zwift

On Bkool simulator

I disconnect the trainer on Bkool, still nothing on Zwift…

Thank you

Hey @Pierre_BAUDE,

I have exactly the same problem. Zwift cannot find the trainer. Did you find a solution?



Hey. We found a solution. We downloaded the Bkool Toolkits App and updated the firmware of the trainer. It works now.

1 Like

It works for all? i already make the update with the toolkit but it doesnt work in my Bkool smart Pro…

1 Like

I have the exact same issue, Zwift will pick up Bkool Power source and Cadence sensor but not the Controllable. I have upgraded Bkool’s firmware to 3.25. It works perfectly with the Bkool and Rouvy app. Am at a loss as to what else that I can do. I’m using Android 10 on a Galaxy 9 phone as I do not have a Windows or Mac machine.

1 Like

Hi Maurice,

Unfortunately the Bkool Pro doesn’t allow Zwift to control it over bluetooth (even though it does work with the Bkool sim and Rouvy), I believe it only works with Zwift using Ant+ on a Windows or Mac.


Thanks Sandy.

Yo lo tengo por ordenador y por sistema Ant+ y bluetooh, y la potencia la obtiene correctamente pero el rodillo no lo detecta y entonces no me reproduce los desniveles. en bkool va todo perfecto. ¿ a qué es debido ?

Hi Javier, have you tried following the instructions here?:


Even I am facing the same challenge on my Bkool Smart Pro Trainer. It was working flawlessly till 2 days before but suddenly it just stopped working and getting connected as a controllable trainer.

Tried updating its firmware which is currently at 3.16 to 3.25 but unable to do that toolkit says “your device already have the latest firmware!”

I am unable to follow your above process too as I cannot find the Windows FILE you have given link to.

Do you thinking Contacting Bkool Support will help to get it upgraded to version?

But I am confused that how come it was working till now from last 1.5 months flawlessly and suddenly it stopped working.