Bkool smartpro black - no connect zwift

This is great, thanks! I managed to translate the Spanish instructions into English for my friend and we have successfully updated their Bkool Pro to work on Zwift now! Here is my version of them:

  1. Uninstall the Bkool simulator software
  2. Donwload the old version from here:
  1. Install the software, but don’t run it yet!
  2. Find and open a file called version.dat
  • In windows it is here C:\Program Files (x86)\Bkool Indoor\BkoolIndoor_Data\StreamingAssets
  • On a mac it is here: Find the Bkool application in “Applications”, right-click to bring up the menu and select “Show package contents”, Navigate to: Contents > Resources > Data > StreamingAssets > version.dat
  1. Edit the file so that the number in it is “5.14” (i.e. the latest version) instead of “3.53” (On the Mac I had to make a copy of the file, edit that, then delete the original and replace it with my new version - there may be a better way but I’m not used to working on Macs)
  2. Open the Bkool simulator and hopefully it won’t prompt you to update it since we’ve tricked it in to thinking it is the latest version
  3. Go to the Pair Devices section and find the Bkool trainer - hopefully you should see the option to enable Ant+ FE-C mode, click this
  4. You might get a message to say that the update failed but this wasn’t actually true in my case - try loading up Zwift and hopefully it should appear as a controllable device
  5. Ride!
1 Like

Hi, I did all the steps and when I connect the bkool using the bkool simulator (ANT+) doesn’t ask me for any update (current version is 3.04) so I cannot enabled ANT+FE-C and of course no luck with zwift… any suggestion? I’m dessesperate…

Are you saying that the version of bkool simulator you have installed is 3.04? If so then you need to uninstall that one and install version 3.53 from the link in step 2

Thanks Sandy, step 2 is the computer software. I talk about the bkool firmware. There is no way that I can update it…I’ve read in another forum that this bkool has an issue with an internal card and won’t update and connect to zwift

To update the firmware of the bkool roller it is necessary to install the bkool software version indicated above. Follow the steps as they describe and you can do it. I just did it with my black BKOOL PRO

1 Like

For some reason the links to the files in my instructions above no longer work. Here are the instructions again with new links to version 3.53 of the Bkool Simulator:

  1. Uninstall the Bkool simulator software
  2. Donwload the old version from here:
  1. Install the software, but don’t run it yet!
  2. Find and open a file called version.dat
  • In windows it is here C:\Program Files (x86)\Bkool Indoor\BkoolIndoor_Data\StreamingAssets
  • On a mac it is here: Find the Bkool application in “Applications”, right-click to bring up the menu and select “Show package contents”, Navigate to: Contents > Resources > Data > StreamingAssets > version.dat
  1. Edit the file so that the number in it is “5.14” (i.e. the latest version) instead of “3.53” (On the Mac I had to make a copy of the file, edit that, then delete the original and replace it with my new version - there may be a better way but I’m not used to working on Macs)
  2. Open the Bkool simulator and hopefully it won’t prompt you to update it since we’ve tricked it in to thinking it is the latest version
  3. Go to the Pair Devices section and find the Bkool trainer - hopefully you should see the option to enable Ant+ FE-C mode, click this
  4. You might get a message to say that the update failed but this wasn’t actually true in my case - try loading up Zwift and hopefully it should appear as a controllable device
  5. Ride!

Hi!

Thanks you for this help,

but in my cas, it’s weird : I can’t activate the bluetooth in the 3.53 app :frowning: the logo “bluetooth” is never never blinking or white, the logo is always grey. I have no problems to link the smart pro in ANT+ but there is no button “switch to ANT FEC control” (perhaps because i am in ANT already : I want to link my device in bluetooth protocol but I cant! It’s the first time)

I think that the downgrade to the 5.14 to the 3.53 let something happened in the interaction for the bluetooth for the bkool app.

PS : in the version 5.14, everything worked great : bluetooth or ant+ but of course no button to switch in ANT FEC protocol…

Thanks a lot for your help.

My configuration :
Bkool smart pro trainer (version uptaded FW 3.1 by bkool toolkit)
Windows 10
Dongle ANT+

And I can see the Bkool smart pro trainer in my bluetooth on windows (i am linked with)… so The trainer is transmitting well in BLE, Windows can see the trainer in BLE,

but the app Bkool can’t see the bluetooth,or just not activate the bluetooth, because the logo bluetooth in the app is grey and not white (if i plug my ant+ dongle, the ANT+ logo come white 2 sec after… impossible to do that with the BLE logo…)

Any idea?

Thank you !

I have a problem because when a I go to “Pair Devices Section” and find Bkool trainner, I do not see the option to enable Ant+ FE-C…

Any suggestion?

Hi Alex. In the Bkool app version 3.53 it should look something like this: https://images.app.goo.gl/HH1e8hBVakBieD629

What do you see?

Hi Jerome, you only need version 3.53 of the Bkool sim to update the trainer to Ant+ FEC, so once this is done you can reinstall version 5.14 if you still want to use the Bkool software. For Zwift bluetooth isn’t very useful as it doesn’t allow the Bkool trainer to be controlled, only Ant+ FEC makes this possible.

What do you see in Bkool 3.53 when you connect the trainer with Ant+? Does it look anything like this: https://images.app.goo.gl/HH1e8hBVakBieD629

Hi Sandy, first thank you for your help

I have fixed the problem, and Zwift is ok with a controllable home trainer with my computer+dongle ant+ (win10)

Can you confirm that it’s not working on Ipad+ ant+ dongle ? I can’t reach the same result on the ipad :frowning:

Excellent Jerome, glad it’s working. I don’t think it will work as a controllable trainer on anything other than a PC or Mac using Ant+, so no iPad, iPhone, Apple TV or Android at the moment unfortunately

Thank you for your help,
sad that it can’t work on a tablet but it’s however a good news :slight_smile:

IMG_2342

as you can see, it’s working very well on my laptop, but, i can’t link the hometrainer in ant+FEC on my ipad, no result (even if i can see the hometrainer in ANT+ or BLE in other app…) so sad.

If there is any change for ios device please let us know :slight_smile: ?

Another time : Thank you a lot!
See ya!
Jerome

Hi Sandy,

Thanks for your help.I have activated it, and it works good on my Mac. Do you know why is not possible to connect Bkool Pro to ZWIFT thouught Ipad with ANT+ Dongle?

Thank you again!

Alex

I don’t know why I’m afraid. I don’t have an iPad (or even a Bkool Pro - my friend has mine) to test it out. Does the iPad pick up any other Ant+ devices in Zwift such as a heart rate monitor?

Hi Guys.
I went through the whole procedure, but when I open the old version of Bkool software and go to Pair Devices the software doesn’t find any available device (my Bkool Pro)

does anyone else have the same problem?

I Can’t enable Ant+ FE-C mode if the software doesn’t find my trainer.

Please help me.
I can’t play with Zwift…

Hi Davide, what happens if you try moving the Bkool right next to the computer?

Sandy, any tricks to change the version.dat file. It tells me it is not editable for some security reason. I tried changing it and resaving with the same name but then it just hangs at the login screen.

Hi @Adriana_Restrep_Iron,

If you can’t edit the version.dat file then you may need to try another method which just replaces the file with a new one:

  1. Open a text editor (e.g. notepad) and in a new file simply write “5.14” (without the quotes)
  2. Save this new file with the name “version.dat”
  3. Delete the original “version.dat” file from the Bkool Sim installation directory
  4. Copy your new file into the above directory