Bkool now supports Zwift?


(Alan Bennetts ETM) #1

From this monday Bkool now supports zwift by allowing enable FE-C control., I have allowed this in bkool but zwift can’t seem to find my unit, any ideas anyone


(Jon Mayfield) #2

Which BKOOL unit do you have?  We’re working on getting a bunch in house right now to test out this new functionality.


(Alan Bennetts ETM) #3

Hi I have the pro 2 months old, I have enabled but Zwift cannot find it, would that be down to zwift software not knowing of this as of yeat as it was only really announced by BKool today?


(Jon Mayfield) #4

Generally FE-C trainers will just automatically work, however only Tacx FE-C trainers have really been fully tested with our code so there could be issues left to resolve.   If you’re sure the trainer is broadcasting and Zwift is in the pairing screen, it should work.  If it’s not there’s probably an issue somewhere.

We’ll have BKOOL trainers tested in-house within the next 7 days and have more info then.


(Jens Pedersen) #5

I just did a very short test. You need to open bsim, remove any pairing if manually paired, find the device again and if your particular model can be updated, there will be a button to enable ANT FE-C (That will tell the trainer to use the public spec rather than their propietary communication I guess). Then Zwift can find it and start listening to broadcasted data.


(Alan Bennetts ETM) #6

I have a friend who says it’s working fine, i have already enabled

What is BSIM?


(Jens Pedersen) #7

Ah, I was referring to the bkool indoor. Used to be bsim, no? Anyway, after I clicked “switch to ANT FE-C” that it said it would update the trainer. After that zwift could see it. Can bkool find the device again after you have updated to FE-C?

Just to be sure, the check mark doesn’t update. The blue text is a button you should press. 


(Alan Bennetts ETM) #8

My Mistake I didn’t hit the Blue Highlighted, thinking the Tick box was the acceptance when in fact as pointed out it’s the Blue Area to press making sure tickbox is uncheck.

So I have it paired now to find the time to do some testing.

Thanks to Jens


(Scott) #9

We’re waiting to test ourselves, but from what we’ve read the ANT+ FE-C trainer control works with Bkool trainers manufactured after August 2014. This applies to both the black Pro and white Classic types. 


(Scott) #10

So we’ve tested the black ‘Pro’ Bkool trainer and it works with Zwift once you upgrade the firmware to be ANT+ FE-C compatible. We’ve created a handy knowledge base article to walk you through the process.


(Morgan morgancicli.it) #11

 

 

I can confirm that the rollers bkool products before August 2014 will not work with Zwift because it is not possible to upgrade the system F-EC


(Steve C) #12

They’ve change their minds now - the older pre-August 2014 trainers will be upgradeable in a month or two - see the DC Rainmaker site.


(Jack Lonker (TV5) KISS (D)) #13

Hi thinking about buying a BKool Pro.  It sounds like Zwift will work based on the knowledge base article.  Am I right in this assumption?


(Steve C) #14

It will work perfectly when riding in Zwift normally. However, in Workout mode, it will set the resistance so that power is about 20% higher than required. There are a few support cases for this and they’re working on a fix.

 

You can get around this for now by turning off ERG mode and using gears/cadence to match the required cadence. I also suppose you could knock about 20% off your FTP just for when you’re doing the workouts