Game Update - November 18th, 2021

Also getting this on two different Windows 10 PCs, I’ve tried updating over a different internet connection as well. It appears that the files on your (Zwift’s) CDN may be corrupted for particular regions. Can you have you system administrators check there are no issues with you geo-graphical CDNs? For example I’m located within the UK. I’ve logged the issue with Zwift support but they keep pointing me at the articles you have already discussed above and do not appear interested in escalating the issue to 2nd or 3rd line technical staff.

Checking the zwift launcher log file I can see that some files are not the expected size, checking the Download folder shows that they are 0 bytes.

For example - Downloads\Zwift\data\Environment\Level Design\Tropics\ShisaStatueGiant.gde (0 KB)

I’m in the UK and have had no trouble updating my PC. There would be huge numbers of people reporting the problem if files were corrupted in general, rather than the few that we’re seeing.

Zwift don’t have their own CDN. They use Amazon for their servers. And I don’t think they have different geographical regions (Zwift seem to use the same US Amazon servers, I think) as far as I can telll.

I get that you and some other people are having trouble, but I think you’re barking up slightly the wrong tree here.

Have you tried downloading over a tethered mobile connection to see if that gets around it? That often helps people with this sort of problem.

Good for you Steve - I’m glad your able to ride! :slight_smile:

I’ve managed to successfully update my laptop using a tethered mobile connection and then manually copied over the missing files to my desktop PC (into the Download folder that the zwift updater had created). These are the main files that consistently fail to download, taken from the log file.

“data\Environment\Level Design\Tropics\ShisaStatueGiant.gde”
“data\Environment\Overpasses\Overpass_Norm.tgax”

This is a workaround to complete the update but is far from ideal. I’m amazed that the updater appears to download each file individually in an uncompressed format.

It is consistent in that the majority of the files are downloaded successfully and always fails on the same files which is what led me to believe this could be an issue with the file repository. So far I’ve worked out that for me cdn . zwift . com is resolving to 4 load balanced cloud front servers. The IP addresses for these change periodically (which could explain perhaps how some people didn’t do anything apart from reboot or try and update at a different time).

I did attempt to manually download the missing files as the location details are all contained within the log file. However I’m unable to manually download files from the file server apart from the version XML file as the other files appear to require authentication to download (403 error).

I’m wondering if cloud front is closing the connection at some point during the download for some reason but I guess no one really cares. Unfortunate for anyone who isn’t technical and is faced with this issue as they will likely just not ride and/or stop their subscription.

For anyone else with the problem you will probably have to download (by running the installer) the missing files reported in the log file through another internet connection (perhaps on another PC) and then copy them across to your desktop if required like I did.

2 Likes

Interesting findings, @David_Knight4 , nice work.

I don’t have any hard numbers at all and this is just conjecture from being on this forum for nearly two years but I believe the percentage of Zwifters who actually come on here is somewhere between 1 and 2 percent. None of the people I know personally come here and it is very rarely I encounter someone I’ve seen here during a Zwift event. It is not easy to find this place from the Zwift homepage, even when you need to.

So the few people you’re seeing complain about this is in reality a huge number when extended by percentage. Zwift should not be lulled into a sense of false complacency by the small number but be alarmed by the how many these few represent.

I too have had very few issues with Zwift or their monthly Bugdates and reading some of these tales of woe makes me very thankful for my good fortune.

I’ve just had an email from Zwift Support which confirms this is an issue they are aware of and that they are working on :slight_smile:

2 Likes

I never said that it wasn’t a serious problem that Zwift should be addressing. But compare the number of people raising this download problem with those reporting in Crash after login (iOS and AppleTV) [November 2021] [1.19.0] (and the latter is only a problem for those who aren’t already logged in). So that one seems to be a much more consistent issue.

My point was that we’d be seeing it raised an awful lot more if files were consistently corrupted for the download. But that’s not to downplay the problem or to say that one problem is more serious than another.

Hopefully Zwift will get it sorted soon.

Thanks @Wes. Any update on the flickering riders on ATV?

Riders relentlessly flickering in and out of visibility in large groups. Has been present since launch of pd3. Can’t be just my end as it’s a discussion point on every large event I join. Was hoping for a fix in this update as it’s bordering on being an eyesight issue or a headache. ATV and 300mbps bandwidth is usually a flawless experience. Can supply a video if you need to see impact.

I have the same issue with BLE and Windows 11.:sob:

I had the Z117 error for several days.

Finally managed to get Zwift to update by tethering my Windows 11 PC to my mobile phone and then updating.

For some reason Zwift wouldn’t update when connected to my home network via wifi.

Might be worth trying this for those still with Z117 errors.

Even that doesn’t help me with the issue.

I’ve had a ticket open with zwift and talked for several.

In the end they concluded the issue was on their part and that they are working on a fix.

They told me to check everyday if the fix was included in the next update. :confused:

2 Likes

Same issue on Android on latest ZC 3.29. Companion map is wrong on this section.


2 Likes

yeah i got that too, same on PC

1 Like

Sound of waterfall in front of Italian villas is missing. It seems to me that sounds given by whale in ocean blvd are missing as well.

Same here - the end of the sprints/koms sounds like a high pressure puncture!

My bike has no handlebars on Apple TV 4k.

A post was merged into an existing topic: No weekly goals displayed

Hmmm! Since the update my Apple Watch has been pairing without using the companion app. Before the up date I had to use the companion app and 40% to 50% of the time I had issues. I am using an Apple TV to run Zwift.

Update 1.19.2 - November 29th
We’ve released update 1.19.2 for PC, Mac, iOS, Android and Apple TV. It contains the following fixes.

  • Fix for a bug where riders with steering devices would be forced to steer left or ride sideways in a pack of riders.
  • Fixed a crash that would occur at login on some devices with Intel graphics.
  • Fixed an issue causing error Z117 and error Z112 in the Zwift Launcher for PC and Mac.
12 Likes

Yay for all youse experiencing these issues!