Game Update - November 18th, 2021

Yes, tried to unpair and repair as well.

Pair all three with the FE-C option (at present you’ve only got controllable paired that way). And ideally disable Bluetooth if you don’t need it for something else.


Still no luck :frowning:

Well at least you’re on the correct pairing now. You’d be better doing spindowns using the Elite My E-Training app anyway.


Dont work on my New Galaxy tab A7 lite. After puljong log in crashes and bass to homse reena.

I noticed 2 issues with the new update and Neokyo

  1. F10 is not working anymore for screenshots (the button works with a opnline virtual keyboard checker so the button is emitting the F10 action so to say). I can only do screenshots via the companion app at the moment (would be great to be able to set an auto screenshot option so it takes a screenshot when an “significant” game notification pops up (route badge, PR, next level, unlock, etc.).

  2. In Neokyo there seems to be an issue with the road feel transmitted to my Tacx Neo2. It makes a pulse on various surfaces where you don’t expect road feel eventhough road feel is turned off in settings. Also I noticed that the road feel is slighly off in activation and deactivation.
    When going to London for example there is no issue.

And please make this and other worlds always available, no more schedules…

Ahojte chci se zeptat proč mi nechce jet zwift na tabletu chci se přihlásit ale celá hra se pak vypne tablet je nový má 8jader a 6gb ram

Hello, since the update I have the problem that Zwift says connected at my HRM but I don’t get any data. When I klick on my HRM at the pairing screen or during a ride, Zwift crashes. I am using a Microsoft surface with windows. Is this problem known? how can I fix this? Thx :slight_smile:

I checked on Windows 10 and screenshots does work.

Was your screen active or another Window was over Zwift when you depressed F10?

I have been triggering my F10 until it ran out of quota per event.

Jakou má grafiku? Myslím že musí mít ARM 64 bit. Ale jestli se Zwift dá nainstalovat, měl by to mít… Jaký tablet to je?

I tried everything (except reinstalling Zwift)

After Nov update i get “connection disconnected” all the time.
Happened exactly the second before i completed Neokyo. Happened again today during the 3R groupride. Just the second before passing the finish line the “connection disconnected” comes and i cannot save the result nor get any race results. It’s like Zwift gets disconnected from the server and never get online again.

Very frustrating!

Never had any issues before October upgrade with bt dropouts occuring and now with Nov upgrade things gets worse with “connection disconnected”

I’m on a gaming pc with win10.

Anyone else getting “connection disconnected”?

Delete knowndevices.xml and start over with pairing your devices.

I don’t lose connection to the devices.
It’s Zwift losing connection to zwift server it seems.

I don’t get any race results, can not save my trainings, all of a sudden I’m all alone in the map. I can’t even exit out of Zwift

Ah right, sorry. I clearly didn’t read your post properly. I’m not aware of there being any issue with the server so you’ll need to check the reliability of the internet connection to your PC. Try restarting your router.

Anyone else seeing crashes around 15-20miles in? 2/3 of my last rides have hit this since the latest update - one when I hit the top of the KOM in the new Neokyo area, and one in Watopia after finishing the Mountain Route. Normally not an issue for me but pretty frustrating since I’m hoping to do a 100km ride this weekend…

Makes sense now. Yep that’s what I did, still no luck… my only hope is Zwift recompile the installer :crossed_fingers:t2:

Also getting this on two different Windows 10 PCs, I’ve tried updating over a different internet connection as well. It appears that the files on your (Zwift’s) CDN may be corrupted for particular regions. Can you have you system administrators check there are no issues with you geo-graphical CDNs? For example I’m located within the UK. I’ve logged the issue with Zwift support but they keep pointing me at the articles you have already discussed above and do not appear interested in escalating the issue to 2nd or 3rd line technical staff.

Checking the zwift launcher log file I can see that some files are not the expected size, checking the Download folder shows that they are 0 bytes.

For example - Downloads\Zwift\data\Environment\Level Design\Tropics\ShisaStatueGiant.gde (0 KB)

I’m in the UK and have had no trouble updating my PC. There would be huge numbers of people reporting the problem if files were corrupted in general, rather than the few that we’re seeing.

Zwift don’t have their own CDN. They use Amazon for their servers. And I don’t think they have different geographical regions (Zwift seem to use the same US Amazon servers, I think) as far as I can telll.

I get that you and some other people are having trouble, but I think you’re barking up slightly the wrong tree here.

Have you tried downloading over a tethered mobile connection to see if that gets around it? That often helps people with this sort of problem.