Elite Qubo Digital Smart B+ Flat Resistance is Off

solved. in my case it was an axis lock that adjusts the resistance. Turn that shaft clockwise 3/4 of a turn.


Salvador when you say axis lock ? I opened mine as still no luck today when powered up the shaft rotates in and moves freely like I presume it should ?

Then it’s ok. The shaft is not locked. Your problem is surely another.

I have exactly the same behavior. Did you solve it?
I’m in contact with Elite support, but no good news for the moment

the Elite support service sent me a document with a procedure to follow to unlock the resistance. For me it did not work.
I have to change the electronic board (but no shipping possible before May 3. Cost 102 €). Can I send you the pdf doc if you wish?
Have a good day


I think I have the same issue. How can I check if it is solved? Shoul it move when I power on ?

Hi Greg, I think they shared with me the same. And I think I have your issue as well :frowning:

Keen to see document still no luck this end either.

yes. With the infrared off, you have to make several turns of the axis. If he doesn’t, it is blocked and you have to help him with a pliers.

1 Like


1 Like

Thx Salvador, I used the pliers as you mentioned and now it turns automatically when I put the power ON.

Now I think that the only thing that I have to do is to try it, right?

it sure works now.

I have the same issue (connect to my 2011 macmini with bluetooth). My Qubo smart it’s too hard on flat, I’m faster riding on hills than flat!
At the beginning it works fine I believe (first two rides), after install Zwift Companion apps and create meetings started the problem. I don’t know if there is some relation.
I’m waiting a ANT+ stick and I hope it fix it or they fix the issue by release.

1 Like

Hello !
I connected the Ant + key and chose FC- for watts, cadence and controller which was recognized immediately in Zwift.
The roller resistance worked well in the ascent of Innsbruck until the middle of the descent.
The resistance jumped and then no longer worked.
I feel I loose it at 92 km/h (so over than 500 watts) wen I ride in middle of a group…
I reconnected again twice but without success.
I try again today…

After a week and a half of frustration, connecting, downloading, uploading, disconnecting etc got one good ride in yesterday. Sorry no miracle answers because tonight now I can’t hit 100watts at 20kmr on the flats standing on the pedals in my smallest gears. So now I have ridiculous resistance. Either zwift or the elite trainer as soon going in the bin.

Are you sure that the mechanical “trolley” with the magnets can move completely from the right to the left?

I suggest you to:

  1. remove the plastic cover from the elite qubo
  2. power on
  3. open the my Etraining app
  4. execute a training
  5. move the flywheel emulating you are cycling
  6. the “carriage” with the 2 magnests should move completely from right to left and back

When you stop the training, the Carriage should move again.

If this works properly you can completely exclude a mechanical issue with your trainer.

Hope this help

1 Like

Thank you Salvador,

I just bought a second hand qubo digital smart b+ and have had this issue. Tried your method and that’s it working! Thanks!

1 Like

since that easy repair I have taken more than 500 km without problems. Greetings

Iam having the same issue. It’s not the trainer because it works perfectly on the Elite My-Trainer app. It’s just when I used zwift, with a flat tire problem included in my case :confused:

Any update to fix this problem?

Hi Salvador, it is me again. Recently I got the same problem like you that the shaft is locked… I used your method & it is freed now. I wonder what we can do to properly maintain the trainer so the shaft won’t lock again. Wonder if it is a good idea to oil the thread of the shaft or the plastic moving surface (saw some oil residue there) ? Any thoughts?