Elite Qubo Digital Smart B+ Flat Resistance is Off

Hello all, I have the same issue, I turned the shaft 3/4 and when I turned the trainer back on, it rotates back to the “locked” position and then seems to stick there again. I can see the trolley is moving originally but then I need to loosen the shaft again because it seems to always get stuck in its original position

I had a similar issue with my Qubo Digital Smart+ suddenly not providing resistance in the middle of a ride . That gave me an unearned ability to generate massive power according to Zwift. I sent an email to Elite’s Customer Care. They walked me through several steps to try to repair it it, but my shaft never moved. They shipped me a new magnet cart that I was able to replace myself and it is running well now… (No more first place segments for me, though!)

1 Like

Great help in this topic! Solved it (also with quick support by Francesco from Elite!)

how did you get a new magnet cart? mine is broken too, do you have that email? i cannot find one anywhere

yh i have the same the trolley gets stuck on the hardest resistance, i think the thread on the cart has gone

Adrian,

I emailed Elite’s support at myetraining@elite-it.com. They shipped the magnet cart and emailed some instructional videos on how to install it. They did have me do several tests (also through video instructions) first to rule out any other problem. The Elite team was very helpful.

Alan

1 Like

Alan, thanks, that is brilliant news, yes i have emailed them too, fingers crossed. Adrian

I tried France yesterday for the first time and set off on my Elite Suito connected via Ant+. It had worked seamlessly before but yesterday the resisitance stayed high during the entire ride, not changing at all and remaining high even on 7% downhills. Does anyone know what might be causing this and how to rectify it please?