Elite Qubo Digital Smart B+ Trainer - No resistance

Hi all, hope you can help me here.

I have recently purchased an Elite Qubo Digital Smart B+ Trainer. I bought the trainer second-hand, but it had only been used for 10 miles. Initially, I was confident the trainer was working well and the first ride on Zwift seemed to be fine (might not have been, not 100% sure as was a flat ride).

However, today I have noticed that there is no resistance changes when going up/down hill in Zwift. Has anyone experienced the same issue? Is this an issue with connection or is the trainer faulty?

I have tried disconnecting everything and then repairing. I have also tried connecting via bluetooth and also through ANT+ dongle. I am using a MacBook Air to run the Zwift app.

Any help would be much appreciated.


Hey mate, I just posted the same question. I have an elite directo smart trainer that is doing the same thing.

I have just managed to get mine sorted this morning, Aaron.

Try the method being talked about at the bottom of this thread:

I opened up my turbo casing and realised the golden axis that controls the resistance wasn’t turning so with some pliers turned it around manually 3/4 of a turn (as seen in document below) and that seemed to fix my problem.


Hope you manage to get sorted.


i too bought 2nd hand,i tried mine on the elite app and it adds resistance then the thread can no longer pull the magnet cradle back it just spins, the thread in the cradle is broken. i did read in here somewhere that someone got a new cradle i am trying to fond that thread this morning.

i was getting no resistance from the uphills and applied that 3/4 of a turn and it worked magically. the only problem is that after working fine for 15min or so, now i cannot go above 100W. i´ll try to calibrate iy but wondering if i did not turn the screw one bit too much…?