Elite qubo digital smart B+ no ressitance


(Lee Crossthwaite) #1

Does anyone know when the issue with elite qubo digital smart B+ will be sorted. Thought I had a issue with my unit after the recent update, Until I found the known issue section. Zwift, my wife would have been upset with you as I nearly bought a new trainer today. Anyhow, still have no ressitance change at all and it’s stuck on the easiest setting. it’s connected via Ant + not BLE. I need to feel the burn!!!


(Steven D) #2

Hi Lee,

There is a known issue for Elite Qubo Digital Smart B+ trainers where the flat resistance is off. However, to my knowledge this issue had to do with BLE pairings and shouldn’t be a problem if you’re using ANT+ to pair your smart trainer to Zwift.

  • My first suggestion would be to check your Elite app and see if there are any newer firmware updates available for your smart trainer. If so, download and install the updates.

  • You’ll also want to double-check your Trainer Difficulty setting and make sure it’s enabled in-game. You can adjust your trainer difficulty from the Settings Menu in-game. Here’s how to do it:

  1. Start a ride in Zwift and once you see your avatar parked on the side of the road, click the ‘MENU’ button in the bottom left of your screen.
  2. Click ‘Settings’, and then locate the ‘Trainer Difficulty’ slider.
  3. By default, Trainer Difficulty is set to 50%, but if you move the slider all the way to the right, it will increase the resistance on your smart trainer to the maximum difficulty when climbing hills (inclines) in Zwift.
  4. If you move the slider all the way to the left, it will eliminate all resistance entirely on hill climbs.
  5. Play around with that setting to find the best fit for your smart trainer.
  6. Furthermore, THIS article does a great job explaining the Trainer Difficulty setting and what to expect from using it in Zwift.

If that doesn’t help, I’d recommend submitting a support request HERE and one of our Zwift support team members will respond via email to further troubleshoot the issue with you. Thanks!


(Lee Crossthwaite) #3

Hi Steven, I got there in the end. I tried starting a ride with zwift many times with no resistance working. Unpaired and paired all my peripherals
And still no joy even though everything was connected. Tried elites myetraining app and still no resistance either. So I connected to zwift with android on my smartphone via blue tooth and it worked perfectly. Then used my PC again (windows 10 with ant +) and that’s now working properly again. Must have been a conflict somewhere with either connections or software.
Many thanks for your time.


(Vincent W.) #4

Hmm that’s super interesting @Crossers, thank you for the details! We’ll investigate why the sudden change happened and update the known issues article wen we receive new information.


(Matthew Colton Wtz) #5

I’m having the same exact issue. I thought it was just my trainer but i have the elite qubo digial. I’m riding in the highest gear on the hardest resistance setting and am only getting like 2.4w/kg on a 11-50 gear with probably a cadence of 90rpms. I have been riding for well over a year on this trainer and suddenly had problems at this most recent update.