Brief loss of resistance after some turns in Watopia [September 2022] [SOLVED]

I was riding the triple flat loos today and noticed that the resistance would cut out completely for about a second after some turns.

I first noticed this after the desert turn around and then at various other turns around the route.

I went back and rode past the desert turnaround again at the end and it happened at exactly the same point so i’m confident it isn’t my set up that’s doing it. It happens exactly as the turn selection box disappears.

Details of config? (trainer, BLE vs. ANT+, device running Zwift…?)

I wonder if it’s related to what was reported here:

It’s not similar to this, that was like a steep drop one way and climb the other.

These were all loss of resistance.

I haven’t changed anything on my set up for months.

Windows 10 using Bluetooth.

Just tried going the opposite direction (volcano flat, the left turn towards epic Kom and the the desert)

Nothing wrong that direction then went to the finish line did a u turn and cam back and it was fine that way too.

Weird. Will investigate further

I have also noticed the same resistance drop, just a fraction of a second and takes place at several turns in Watopia. I am on AppleTV with latest updates.

1 Like

got this again tonight.

Happens around Watopia at turnings, happens immediately after the pop up turn selection disappears and last a fraction of a second but enough time to spin out.

I’m using bluetooth on windows 10.

Rode the chasing the sun route on makuri/neokyo this morning, no loss of resistance on turnings at all, no change to my set up.

Will try watopia again this evening to see if the issue returns.

I have done some more investigating on this (not that many people seem to care!)

I have used a different PC, a laptop with internal bluetooth, my main zwift PC uses a bluetooth dongle.
The laptop has the same mini drops in resistance and only in watopia and always at junctions.

I am confident this isn’t just my set up as it is exactly the same on two different PCs (laptop is about a meter from the trainer with HDMI cable to the tv)
I have no similar experiences on any world except watopia, it only happens at junctions so I am pretty sure it isn’t my trainer.

these are the two drops - i tried keeping cadence steady through them as I knew the drops were coming.

I rode france this morning with exactly the same set up and no problems. I have done workouts with no problems. It is only Watopia and only junctions.

Wonder if this relates in some way to the gaps in the road some have seen on other worlds, as in if there are misaligned ground levels on spots and the resistance value sent to your trainer is momentarily wrong. You’d need to know the exact times, but have a look in the log file and see if there’s evidence of a random (and inaccurate) gradient sent to your trainer.

I had thought that too - it is as if the junction have expanded and there is a gap just the other side of it where you fall into nothingness for a second before finding land again!

but it is weird it only happens in watopia that doesnt have that issue and France and Maukuri islands that have that issue are fine

I had this happen to me multiple times on the Eastern Eight route yesterday. Running Zwift on iOS.

1 Like

Not just a windows thing then, I might try android later to see if it happens then too

Same thing here, Windows 11 and Elite Suito over BLE, noticed in almost all intersections of Beach Island Loop.

1 Like

I have exactly the same issue. At the same spots on the map i got resistance drops. I use the kickr v5 and kickr climb. It is extremly noticable with the climb because it moves complety down at these spots. Never had issues like this before. This must be software related. I’m using win11 and a bluetooth dongle.

1 Like

seems to be a windows bluetooth problem then.

It is like there is a little gap in the map after turns where the resistance drops to zero for a second then goes back to how it should be.

1 Like

Hopefully the developers will fix this soon. It sucks. It’s a gamebreaker bug for me.

1 Like

Yeah, it makes watopia a nightmare with briefly spinning out all the time, i kind of know where they all are now so can manage it now.

1 Like

It seems to be related to “game_1_28_ftms_road_grade_lookahead_time_exposed”, I disabled it and didn’t feel the resistance loss. Tested in the route “Beach Island Loop”.


interesting - how did you disable that? I can test it too

It’s a feature enabled by a server response, need to patch in memory (not simple). I posted it here so that a developer can check it (if someone is investigating this).