Apple TV 4k remote issues


(Brian Griffin) #21

I have had this a few times. Ended up unplugging my apple unit and letting it reset. At first I thought it was just a low battery level of the remote but after charging the remote I didn’t have any changes in remote pairing. So now when it happens I go straight to the apple unit so I don’t waste time and miss any rides I’m signed up for. Try it next time


(Joseph Paterson) #22

I tried using the remote app on my iPhone yesterday instead of the Apple TV remote, and had no issues whatsoever, much more reliable.


(Alf Kempf) #23

Only the menu function works on my Apple TV remote. It would be great to get this fixed because the app is pretty unuseable unless you can make selections


(Eiki Egilz) #24

I have the exact same issue, using the Apple Tv 4k as well. Remote is 100% ok in other apps … but the selections of workouts / tracks is really hard with the remote control as descibed above. Like russian roulette!


Conflict between Stryd and KickR Core 2018
(Vincent W.) #25

Investigating…


(Andy Ball) #26

I get this same issue on brand new Apple TV that arrived today , I can’t move the cursor left or right at all (or to allow change of focus to different buttons)

Works ok in other Apple TV apps

Update (21/10/2018) . The Apple TV received a systems update , which has fixed the issue for me.


(Eiki Egilz) #27

I also have the latest update of the Apple Tv 4k … this issue is NOT fixed. @Andy, just try going under the workouts and PLANS, there you will see this malfunctioning of the remote using Zwift. Try to scroll through the list of PLANS and select some particular item … it will become a Russiand roulette.

@Vincent W. please confirm that you’ve guys have been able to re-produce the problem and you’re looking into it?
Check my attached image, it will show exacly what the problem is … it’s the selected item. You can see that the “Gravel Grinder” is selected, because you see the description for it on the right screen, while on the left it’s as the “Build Me Up” is selected, which is an incorrect behaviour. The selected-items is incorrectly highlighted, i.e. not highlighted at all … the first item in the list when you come into this screen will always be the one “selected” although you scroll into other items in the list.


(Eiki Egilz) #28

@Bart Roberts, have a look at my post at the bottom of this thread, it explains the problem very well, with an image to show the bug to help Zwift fixing it.


(Vincent W.) #29

Forwarding this over, will get an update.

Edit: The highlighted training plan issue is a bug that we’ve reported, the fix just hasn’t shipped yet and should be in the next update.

Can you update us on the workout menu scrolling that you originally posted about? This should have been improved. @lord02


(Eiki Egilz) #30

@Vincent I can confirm the Workout scrolling works very well now on the Apple Tv 4k.

Excellent to hear to you guys are working on the Plans scrolling … that’s the one broken. I even tried changing the Apple Tv’s 4K resolution down from 4K HDR @50Hz down to 1080p and restarting both the Apple Tv 4k and the Zwift, without luck. I know Kodi had a very similar problem when I set my Shield to 4k resolution. The menu in Kodi behaved very similar to this, you never knew what was selected, the wrong items got highlighted. The “fix” there, was to set the resolution to 1080p temporarily untill they fixed the issue. That’s not the case here, 1080p doesn’t “fix” the problem. I’ll be monitoring this thread, and keep checking - thanx again @Vincent


(James Mountford) #31

@Vincent - newest (Apple 5th gen) remote/apple tv combo still not scrolling at all on workouts page. Do I need to re download or update?


(Steve Ricketts (C68)) #32

Don’t think I’d say it’s just the workouts that are difficult to select… routes, bikes, shirts, wheels, basically anything you have to scroll to select. Extremely difficult with the Siri remote. Downloaded the Apple TV remote app (for my ATV 4k) and it works much better.


(Eiki Egilz) #33

@James_Mountford yes, upgrade to get that one screen fixed.

@Steve_Ricketts I agree on that screen - everything there is also difficult to select, where you have a scrolling list.

I would have thought everything will be fixed, in all screens, when Zwift gets the hang of it, on one particular screen but that doesn’t seem to be the case, since “Plans” screen is now fixed, but the other ones are still broken @Vincent.

Please upvote this bug so Zwift will put focus on the issue. . Loads of people are using AppleTv 4K with Zwift.


(Jake Weber) #34

Just had this problem for the first time today. Using AT4K. The finger mouse of the remote cannot move, it only selects. Basically forcing me to do the workout I selected yesterday. Nothing needs to be updated and everything is charged. Only happens on Zwift.


(Eiki Egilz) #35

I just tried connecting my Logitech K810 keyboard with the Apple Tv 4k, and then started Zwift!
When Zwift is started the keyboard does NOTHING, i.e. it can’t control anything!

This keyboard works in every single other app on the Apple Tv 4k, except for Zwift … was trying if this would fix the navigation problems the remote has inside Zwift, without any luck.

@Vincent is Zwift looking into this issue, full force? This is basically my only complaint about Zwift, I’m really happy with it, except for this remote issue, which is pretty big.

https://www.amazon.com/gp/product/B0099SMFVQ/ref=oh_aui_search_detailpage?ie=UTF8&psc=1


Scrolling with Apple TV remote is painfully impossible
(B Durruti) #36

Still a big issue. Cant select the course I want. Painful navigation!


(Eiki Egilz) #37

@Vincent please add this to the “known issues” ?

https://forums.zwift.com/c/known-issues ?


Shortcut to trainer calibration on Apple TV
(Vincent W.) #38

Are you trying to connect more than 3 bluetooth devices when you have that keyboard?
Edit: Scratch that, not making a Known Issues post since the training plan highlight issue isn’t a blocker and it’ll be fixed in a coming update.


(Vincent W.) #39

Are you unable to move your Apple TV cursor as well? Have you updated to the latest version?

@Jake_Weber Are you still having this issue after closing the app completely and restarting?


(Eiki Egilz) #40

No, I’m not even at the pairing devices screen … so there’s just the native AT4k remote control connected to it, nothing else. The Keyboard stops working the moment I enter Zwift, and it starts working the moment I leave Zwift ( by pressing the Menu or Home button on the remote to get me out of Zwift ).

@Vincent when will you release the updated version which handles the training-plan screen? I don’t really need to pair my keyboard with Zwift, I was just trying to overcome the remote control issues. Thanks for all your support on the forum.