Apple TV - Workout/Route Selection


I recently acquired an Apple TV to run Zwift, and all has been working GREAT with the exception of 1 thing.

I’m currently doing a workout program, and whenever I select the daily workout I want to do that day, a secondary or “pop up” screen comes up which allows me to select a Zwift world and route. Using the Apple TV remote, I’ve tried both the “touch” portion of the remote and also the arrows but I have the same issue. The selection on the pop up screen moves up and down with no issues, but when I press either the left or right button, instead of the selection change on the pop up, is the screen on the background (the workout selector) that moves.

I’ve thought about perhaps using a Bluetooth mouse but the Apple TV doesn’t have a pointer, so I feel like that will not work???

Any help would be appreciated! Thank you.

Works fine here. Did you try deleting the app and reinstall it?

Which ATV remote do you have?

1 Like

No… maybe I’ll try that today.

The grey one that comes with the 4K Apple TV version… it’s grey, circular touch and quite a few buttons under the touch area.

I tried posting a link but the forum would not let me.

I’m having exactly the same issue, and it’s really annoying.
I can only select the Zwift worlds in the left column when selecting the daily workout from my training plan.

I’m using the Apple TV 4K (2022) with the latest Apple Siri Remote gen 3.

1 Like

I googled forever and this didn’t come up so I also made a topic and tweeted at them. Same issue. ATV Gen 3 w/ Ethernet. Can only move up and down.


Tried deleting the app and reinstalled, same problem.

Please let me know if they reply… I tried deleting the app today and reinstalling but same problem.

This is quite frustrating since I had to delete the app and then use my Ipad to get to the workout my coach scheduled me to do.

There is a video of the issue I have all with Apple TV 4K on another bug posted by [Graeme Hutchison] - Works fine for selecting routes in the left column but scrolls background underlying plans with left and right buttons on remote.

I am having the exact same issue with my Apple TV 4K, tried all the same fixes as above but no result either.

Someone please help, this is super annoying!

1 Like

Trying to launch the any workout within Apple TV seems extraordinarily clunky. The mouse pad and arrows on the remote don’t allow selection of the button needed to proceed. Sometimes I get lucky and it actually works, but very frustrating and often causes delays

1 Like

Not the same, but similar issues over here.
There is seemingly no way to simply select the next workout in a training plan.

Whenever I go to the training section, I have to re-highlight / scroll down to the training plan I’m in, then enter to the workout overview. This brings me to the final workout and I have to scroll back to the workout I am actually wanting to start.

It’d be nice if there was at least the possibility to continue with the training plan / the next workout in a running training plan.

All this is on AppleTV 4K.
It’s a minor inconvenience though compared to what you guys above experience.

1 Like