[Apple TV] Can't select route with new remote


Recently I purchased an Apple TV to run Zwift. It’s the HD 2021 (non-4K) edition that comes with the new Siri remote.

Unfortunately, It’s nearly impossible to choose a route. When I try to select one it just skips over several routes and it doesn’t matter if I use the click or the swipe buttons. One click down skips like five routes and the tiniest little swipe at least three. It requires a lot of luck and attempts to get the route that I want. All the other menu’s work just fine. Edit: actually I can’t properly select anything from the event list in the main menu either. Bummer.

Is this a bug? Am I doing something wrong or is there a setting I can change? I’ve been reading about how a recent updates is supposed to have solved some issues with the new remote. But I’m running the most recent version of Zwift (1.18.1 (85684)) on my Apple TV.

I made a gif that shows what I mean. Each scroll is just one click or tiny swipe.

My humble apologies if this question has been answered anywhere else and I overlooked this. But I couldn’t find it.

Not sure if the answer will be found here, but take a look at this and see if it helps: ZWIFT Update: New AppleTV Remote Now Supported! [AppleTV4K 2021 Remote] - YouTube


It seems that I have solved the issue. Apparently it was my own lack of knowledge on how to handle the remote. You have to ‘pause’ the scrolling with the round center button. It’s still not optimal, but I guess it works now.

Thread can be closed.